Bug 324141 - yum-rhn-plugin doesn't work with yum 3.2.5 and 3.2.6
yum-rhn-plugin doesn't work with yum 3.2.5 and 3.2.6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
: 362541 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 22:47 EDT by Fajar A. Nugraha
Modified: 2008-05-21 10:27 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2008-0360
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:27:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fajar A. Nugraha 2007-10-08 22:47:24 EDT
Description of problem:
yum-rhn-plugin doesn't work with yum 3.2.5 and 3.2.6

Version-Release number of selected component (if applicable):
yum-rhn-plugin-0.4.3-2.el5
yum-3.2.5 or 3.2.6

How reproducible:
always

Steps to Reproduce:
1. upgrade to yum 3.2.5/3.2.6
2. yum list yum
  
Actual results:
# yum list yum
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
https://xmlrpc.rhn.redhat.com/XMLRPC/GET-REQ/rhel-x86_64-server-cluster-5/repodata/repomd.xml:
[Errno 14] HTTP
 Error 405: Method Not Allowed
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository:
rhel-x86_64-server-cluster-5. Please verify its path and try again


Expected results:
# yum list yum 
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up repositories
rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-cluste 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-hts-5  100% |=========================| 1.2 kB    00:00
rhel-x86_64-server-vt-5   100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-fastra 100% |=========================| 1.2 kB    00:00
rhel-x86_64-server-supple 100% |=========================| 1.4 kB    00:00
rhel-x86_64-server-5      100% |=========================| 1.4 kB    00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Installed Packages
yum.noarch                               3.0.1-5.el5            installed


Additional info:
Comment 1 Pradeep Kilambi 2007-11-01 16:26:33 EDT
*** Bug 362541 has been marked as a duplicate of this bug. ***
Comment 2 RHEL Product and Program Management 2007-11-02 21:35:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 James Antill 2007-11-05 19:18:59 EST
 I'll be trying to move to at least 3.2.7 (probably 3.2.7 with select patches
from upstream).
Comment 5 Fajar A. Nugraha 2007-11-09 00:58:21 EST
yum-rhn-plugin-0.5.2-3.el5 from RHEL-5.1 seems to work fine with yum
git-snapshot edbdf5ee813cd329f3272d0902b220c1312d3a07 (probably works with other
3.2.x release as well, but I didn't check that).

It'd be nice if there were a fix notification on this bugzilla before the
package actually comes out though.
Comment 6 John Matthews 2008-01-08 17:56:58 EST
I took a RHEL 5.1 box with yum-rhn-plugin-0.5.2-3.el5 and upgraded yum to "3.2.8".

Ran a series of:
"yum list", "yum search", "yum remove", "yum install" 

No problems observed


Also repeated above tests with latest rhnplugin.py from svn (rev #135245)

No problems observed

 

Comment 9 Cameron Meadors 2008-02-19 13:18:16 EST
Looks good with 3.2.8-6.el5. No errors when exercising yum-rhn-plugin.
Comment 11 errata-xmlrpc 2008-05-21 10:27:22 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0360.html

Note You need to log in before you can comment on or make changes to this bug.