Bug 32428 - XFree86-xfs-4.0.3-1: warning in post-install script
Summary: XFree86-xfs-4.0.3-1: warning in post-install script
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-20 21:25 UTC by Olivier Baudron
Modified: 2007-04-18 16:32 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-03-20 21:25:33 UTC


Attachments (Terms of Use)

Description Olivier Baudron 2001-03-20 21:25:30 UTC
Upgrading XFree86-xfs caused the following warning:

# rpm -Uvh XFree86-xfs-4.0.3-1.i386.rpm
grep: /etc/X11/XF86Config-4: No such file or directory

The problem is in the post-install script:

for config in /etc/X11/XF86Config /etc/X11/XF86Config-4 ; do
	...
	if grep -q "unix/:" $config >& /dev/null && \
	...
done

Through /bin/bash, there would not be any problem, but since rpm uses
/bin/sh, I suggest to use the usual syntax:

	if grep -q "unix/:" $config > /dev/null 2>&1 && \

Comment 1 Bill Nottingham 2001-03-20 22:58:17 UTC
Yup, this should be fixed in -2.


Note You need to log in before you can comment on or make changes to this bug.