Bug 324401 - .src.rpm is not a source rpm
.src.rpm is not a source rpm
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: printer-filters (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 324411 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 04:40 EDT by Kasper Dupont
Modified: 2009-01-07 13:09 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 05:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kasper Dupont 2007-10-09 04:40:44 EDT
Description of problem:
http://download.fedora.redhat.com/pub/fedora/linux/updates/7/SRPMS/printer-filters-1.1-1.fc7.src.rpm
is not a source rpm file.

Version-Release number of selected component (if applicable):
printer-filters-1.1-1.fc7.src.rpm

How reproducible:
Every time.

Steps to Reproduce:
1. rpm -qp --qf '%|SOURCE?{source}:{binary}|\n'
http://download.fedora.redhat.com/pub/fedora/linux/updates/7/SRPMS/printer-filters-1.1-1.fc7.src.rpm
  
Actual results:
binary

Expected results:
source

Additional info:
Comment 1 Lubomir Kundrak 2007-10-09 05:00:14 EDT
Thanks for your report Kasper. Please note that the package is correct, but your
query seems rather wrong. You are assuming that source packages do actually
contain source files, which is not right for this one. I suggest you replace
your query with something this to get accurate results:

rpm -qp --qf '%|SOURCERPM?{binary}:{source}|' printer-filters-1.1-1.fc7.src.rpm

Did this cause any problems to any of existing tools? Did this solve your
problem; may I close this report?
Comment 2 Parag Nemade 2007-10-09 05:15:20 EDT
Kasper,
  This is kind of meta-package. Such types of packages are created only to pull
other packages by installing only meta-package.
  So no wonder to see src.rpm without source files. You will see more such
packages in CVS also and in future now.
Comment 3 Parag Nemade 2007-10-09 05:18:53 EDT
I guess bug version should be reported as F7 and not fc6.
Comment 4 Kasper Dupont 2007-10-09 05:48:19 EDT
The tool predates fedora core - and was never part of the distribution. I have
had to make lots of changes to make it still work, so it might not be feasible
to track down the origin of the use of SOURCE rather than SOURCERPM. Closing as
not a bug as this turned out to be a bug in that third party script rather than
this package. Thanks for the clarification.
Comment 5 Kasper Dupont 2007-10-09 05:50:39 EDT
*** Bug 324411 has been marked as a duplicate of this bug. ***
Comment 6 Kasper Dupont 2007-10-14 10:59:47 EDT
I just realized, that using SOURCERPM is not correct either. There exist tools
to build binary rpm packages without a source rpm package as the starting point.
But looking in the source code of rpm itself reveals that the correct solution
is to use SOURCEPACKAGE. (But still the bug is in the third party script).

Note You need to log in before you can comment on or make changes to this bug.