Bug 324561 - LiveCD won't load boot menu due to vesamenu.c32: attempted DOS system call error
LiveCD won't load boot menu due to vesamenu.c32: attempted DOS system call error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
9
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 05:28 EDT by Diego Escalante Urrelo
Modified: 2013-01-09 23:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 17:38:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (4.38 KB, image/png)
2008-08-05 14:54 EDT, Jason Taylor
no flags Details

  None (edit)
Description Diego Escalante Urrelo 2007-10-09 05:28:11 EDT
Description of problem:
Fedora won't show me the nice graphic menu for booting the livecd in an old pc,
the reason given is pretty particular:
vesamenu.c32: attempted DOS system call error

Other distributions show a graphical grub (I'm supposing it's grub what you use
in the boot options screen) just fine. The CD is ok and works since on other pcs
it takes me to the nice boot options screen.

Version-Release number of selected component (if applicable):
Fedora 8, test3, i686 livecd (and previous versions, at least since 5)

How reproducible:
Boot Fedora livecd on my old pc :)
  
Actual results:
A boot: prompt is offered and you have to type linux (enter) to boot, of course
if you have no idea what's "boot:" you are not gonna make it past there.

Expected results:
Fedora shows the nice graphical boot options menu

Additional info:
Fedora boots just fine, the problem is just the boot options menu.
Check the interweb, it's full of reports of this problem. I would say this is an
outstanding but, it's keeping newbies from installing fedora or even trying it
(if they have the fedora unfriendly hardware).
Comment 1 Jeremy Katz 2007-10-09 10:33:27 EDT
How old of a PC is this?  And does it have a current BIOS?
Comment 2 Diego Escalante Urrelo 2007-10-09 10:43:26 EDT
While booting, my good ole pc says:
AMIBIOS 1999, American Megatrends
Release 01/31/2002S

Among other things, I bought this computer back in 2002, it wasn't top of the
line tech so I can imagine it was 2001 technology or something close (Jan 2002
makes sense reading the bios release date).
It's a "PC-CHIPS" mainboard, quite cheap and popular for that time, it features
SiS components all around: video, lan, sound, ide.

Anything else I can add?
Comment 3 Jeremy Katz 2007-10-09 11:01:41 EDT
Looking for a new BIOS is probably my first suggestion.  Because that's should
be new enough to correctly run VESA graphics code in the BIOS
Comment 4 Jason Taylor 2008-08-05 14:54:58 EDT
Created attachment 313474 [details]
Screenshot
Comment 5 Jason Taylor 2008-08-05 14:56:13 EDT
Comment on attachment 313474 [details]
Screenshot

This is occuring when I try to install F10-Alpha and/or the current Rawhide using either the netinstall.iso or the boot.iso. I am trying to install F10-Alpha/Rawhide into a KVM instance (base system is x86_64 Fedora 9 fresh install). I was able to install/run F8 just fine.
Comment 6 Peter Jones 2008-09-12 16:26:40 EDT
Reassigning to the kvm guys.  See the thread at http://marc.info/?l=kvm&m=121639849313140&w=2
Comment 7 Jason Taylor 2008-09-12 17:15:39 EDT
So hpa sent a patch for qemu to apparently fix this in July. The last build on F9 was kvm-65-7 which doesn't include the patch. So looks like an updated build would fix this?
Comment 8 Glauber Costa 2008-09-15 08:56:00 EDT
I've already sent a build to the update system that should fix the issue.

It's https://admin.fedoraproject.org/updates/F9/FEDORA-2008-7437.

I believe you can help this getting updated by testing and increasing its karma in case it really works for you too.

Note You need to log in before you can comment on or make changes to this bug.