Bug 324641 - Updating openoffice.org.org fails, requires "libjawt.so(SUNWprivate_1.1)"
Updating openoffice.org.org fails, requires "libjawt.so(SUNWprivate_1.1)"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 06:29 EDT by Espen Stefansen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 09:10:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Espen Stefansen 2007-10-09 06:29:08 EDT
Description of problem:
Yum won't update openoffice.

Version-Release number of selected component (if applicable):
[root@68482 ~]# rpm -qa | grep openoffice | sort
openoffice.org-calc-2.3.0-5.1.fc8
openoffice.org-core-2.3.0-5.1.fc8
openoffice.org-draw-2.3.0-5.1.fc8
openoffice.org-graphicfilter-2.3.0-5.1.fc8
openoffice.org-impress-2.3.0-5.1.fc8
openoffice.org-langpack-en-2.3.0-5.1.fc8
openoffice.org-langpack-nb_NO-2.3.0-5.1.fc8
openoffice.org-langpack-nn_NO-2.3.0-5.1.fc8
openoffice.org-math-2.3.0-5.1.fc8
openoffice.org-writer-2.3.0-5.1.fc8
openoffice.org-xsltfilter-2.3.0-5.1.fc8
[root@68482 ~]# rpm -qa | grep java | sort
java-1.5.0-gcj-1.5.0.0-14.fc7
java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8
java-1.7.0-icedtea-plugin-1.7.0.0-0.16.b19.snapshot.fc8
java_cup-0.10-0.k.6jpp.1
system-switch-java-1.1.2-1.fc8
tzdata-java-2007h-1.fc8


How reproducible:
Everytime

Steps to Reproduce:
1. yum update
2.
3.
  
Actual results:
Resolving Dependencies
--> Running transaction check
---> Package openoffice.org-calc.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-draw.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-impress.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-xsltfilter.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-langpack-nn_NO.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-writer.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-langpack-en.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-math.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-langpack-nb_NO.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-graphicfilter.i386 1:2.3.0-6.1.fc8 set to be updated
---> Package openoffice.org-core.i386 1:2.3.0-6.1.fc8 set to be updated
--> Processing Dependency: libjawt.so(SUNWprivate_1.1) for package:
openoffice.org-core
--> Processing Dependency: libjawt.so for package: openoffice.org-core
--> Finished Dependency Resolution
Error: Missing Dependency: libjawt.so(SUNWprivate_1.1) is needed by package
openoffice.org-core
Error: Missing Dependency: libjawt.so is needed by package openoffice.org-core


Expected results:
openoffice should be upgraded

Additional info:
Comment 1 Caolan McNamara 2007-10-09 06:39:08 EDT
What does rpm -q --whatprovides libjawt.so say, I presume the problem is that
icedtea is not installed and isn't getting pulled in, but I don't like
"libjawt.so(SUNWprivate_1.1)", libjawt.so" would be ok but the other locks up to
icedtea.
Comment 2 Caolan McNamara 2007-10-09 06:44:41 EDT
caolanm->fitzsim: Should "SUNWprivate_1.1" be exported, the OOo rpms seems to
have ended up requiring it after linking libofficebean.so against libjawt.so,
i.e. is this something for me to fix somehow or something for icedtea ?
Comment 3 Espen Stefansen 2007-10-09 06:46:04 EDT
It gives no result.
Comment 4 Caolan McNamara 2007-10-09 07:09:24 EDT
Well you from #1 have java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8
installed, here I have...

rpm -q java-1.7.0-icedtea
java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8

rpm -q --provides java-1.7.0-icedtea|grep jawt
libjawt.so  
libjawt.so(SUNWprivate_1.1)

rpm -q --whatprovides libjawt.so
java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8
libgcj-4.1.2-31

If I rpm --erase my OOo and my java-1.7.0-icedtea and yum install
openoffice.org-writer it all gets pulled in correctly, does rpm -q --provides
java-1.7.0-icedtea now show libjawt ? Is there a
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/lib/i386/libjawt.so ?

Comment 5 Espen Stefansen 2007-10-09 08:11:02 EDT
I just used yum to remove openoffice and icedtea. And then installed
openoffice.org-writer. It now installs correctly. :)

But now i got 2 other problems:
1. no openoffice icons is showing in startmenu
2. can't install java-1.7.0-icedtea-plugin
--> Processing Dependency: java-1.7.0-icedtea = 1.7.0.0-0.16.b19.snapshot.fc8
for package: java-1.7.0-icedtea-plugin
--> Finished Dependency Resolution
Error: Missing Dependency: java-1.7.0-icedtea = 1.7.0.0-0.16.b19.snapshot.fc8 is
needed by package java-1.7.0-icedtea-plugin

But this should be a icedtea problem, not openoffice.

Another things is that if i run 'rpm -q --whatprovides libjawt.so', i still
doesn't get any results. 
Comment 6 Caolan McNamara 2007-10-09 08:32:29 EDT
Sounds all a big cocked-up to me. Right now what is the output of...

rpm -q java-1.7.0-icedtea
and
ls /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/lib/i386/libjawt.so
assuming that your architecture is ix86
Comment 7 Espen Stefansen 2007-10-09 08:46:17 EDT
Here's the output: 
[root@itse ~]# uname -a
Linux itse 2.6.23-0.222.rc9.git4.fc8 #1 SMP Sat Oct 6 13:53:58 EDT 2007 i686
i686 i386 GNU/Linux
[root@itse ~]# rpm -q java-1.7.0-icedtea
java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8
[root@itse ~]# rpm -q --provides java-1.7.0-icedtea|grep jawt
libjawt.so  
libjawt.so(SUNWprivate_1.1)  
[root@itse ~]# rpm -q --whatprovides libjawt.so
[root@itse ~]# ls -l /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/lib/i386/libjawt.so
-rwxr-xr-x 1 root root 3044 2007-09-27 21:22
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/lib/i386/libjawt.so
Comment 8 Caolan McNamara 2007-10-09 08:55:06 EDT
None of this looks like an OOo bug, you might be better off just using one of
the mailing lists and looking for help.

[root@itse ~]# rpm -q --provides java-1.7.0-icedtea|grep jawt
libjawt.so  
libjawt.so(SUNWprivate_1.1)  
[root@itse ~]# rpm -q --whatprovides libjawt.so

is clearly inconsistent with each-other. You have some generic trouble here,
perhaps with your rpm database. Here's what I'd do, but it's out of my area...

yum clean all
rm /var/lib/rpm/__db.00*
and then check
rpm -q --provides java-1.7.0-icedtea|grep jawt
rpm -q --whatprovides libjawt.so
and if they are still inconsistent then rpm --erase java-1.7.0-icedtea and yum
-y install it again. 
Comment 9 Espen Stefansen 2007-10-09 09:40:47 EDT
I tried removing the rpm-databases and reinstalling it again, but i get the same
error. :( So i opened a new bug, bug#324861 and set the component to
java-1.7.0-icedtea.
Comment 10 Thomas Fitzsimmons 2007-10-09 14:52:14 EDT
(In reply to comment #2)
> caolanm->fitzsim: Should "SUNWprivate_1.1" be exported, the OOo rpms seems to
> have ended up requiring it after linking libofficebean.so against libjawt.so,
> i.e. is this something for me to fix somehow or something for icedtea ?

It's an IcedTea issue that I'll have to investigate.  The JAWT_GetAWT symbol is
versioned in IcedTea's libjawt.so but not in any of the 1.5-level JDK's
libjawt.so's.  I'll let you know if an OOo rebuild is required.
Comment 11 Thomas Fitzsimmons 2007-10-09 17:09:28 EDT
(In reply to comment #10)
> (In reply to comment #2)
> > caolanm->fitzsim: Should "SUNWprivate_1.1" be exported, the OOo rpms seems to
> > have ended up requiring it after linking libofficebean.so against libjawt.so,
> > i.e. is this something for me to fix somehow or something for icedtea ?
> 
> It's an IcedTea issue that I'll have to investigate.  The JAWT_GetAWT symbol is
> versioned in IcedTea's libjawt.so but not in any of the 1.5-level JDK's
> libjawt.so's.  I'll let you know if an OOo rebuild is required.

Sun added symbol versioning to libjawt.so starting with Java 6.  So if OOo is
built against a Java-6-or-later JDK, it will require the versioned libjawt.so.
Comment 12 Caolan McNamara 2007-10-10 09:10:02 EDT
Well we build against what's there, so if that's the way it is in Java 6 we'll
just have to live with it. I don't see a OOo issue here then.

Note You need to log in before you can comment on or make changes to this bug.