Bug 325001 - update to rc1 fails if xen installed
update to rc1 fails if xen installed
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 10:55 EDT by Marc Grimme
Modified: 2009-12-14 16:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Grimme 2007-10-09 10:55:39 EDT
Description of problem:

update to rc1 fails if xen installed
Version-Release number of selected component (if applicable):
xen-3.0.3-41 is missing

How reproducible:

update



Steps to Reproduce:
1.yum update
2.
3.
  
Actual results:
[root@axqa01_1 ~]# yum update
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
Setting up Update Process
rhel-i386-server-cluster- 100% |=========================| 1.4 kB    00:00
rhel5                     100% |=========================|  951 B    00:00
rhel-i386-server-5-beta   100% |=========================| 1.2 kB    00:00
comoonics-addons          100% |=========================|  951 B    00:00
comoonics-preview         100% |=========================|  951 B    00:00
rhel-i386-server-vt-5-bet 100% |=========================| 1.2 kB    00:00
rhel-i386-server-5        100% |=========================| 1.4 kB    00:00
rhel-i386-server-cluster- 100% |=========================| 1.4 kB    00:00
rhel-i386-server-vt-5     100% |=========================| 1.4 kB    00:00
rhel-i386-server-cluster- 100% |=========================| 1.2 kB    00:00
comoonics-preview-i386    100% |=========================|  951 B    00:00
rhel-i386-server-cluster- 100% |=========================| 1.2 kB    00:00
Resolving Dependencies
--> Running transaction check
---> Package lvm2.i386 0:2.02.26-3.el5 set to be updated
---> Package system-config-kdump.noarch 0:1.0.12-1.el5 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.99-2.el5 set to be updated
---> Package cups-libs.i386 1:1.2.4-11.14.el5 set to be updated
---> Package system-config-network.noarch 0:1.3.99-2.el5 set to be updated
---> Package initscripts.i386 0:8.45.17.EL-1 set to be updated
---> Package libpcap.i386 14:0.9.4-11.el5 set to be updated
---> Package pm-utils.i386 0:0.99.3-6.el5.17 set to be updated
---> Package rpm-libs.i386 0:4.4.2-47.el5 set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.34.el5 set to be updated
---> Package tcpdump.i386 14:3.9.4-11.el5 set to be updated
---> Package crash.i386 0:4.0-4.6.1 set to be updated
---> Package xorg-x11-drv-mga.i386 0:1.4.2-6.el5 set to be updated
---> Package kmod-gfs.i686 0:0.1.19-6.el5 set to be updated
---> Package xorg-x11-drv-i810.i386 0:1.6.5-9.6.el5 set to be updated
---> Package mcstrans.i386 0:0.2.6-1.el5 set to be updated
---> Package popt.i386 0:1.10.2-47.el5 set to be updated
---> Package selinux-policy.noarch 0:2.4.6-104.el5 set to be updated
---> Package coolkey.i386 0:1.1.0-5.el5 set to be updated
---> Package hwdata.noarch 0:0.211-1 set to be updated
---> Package openais.i386 0:0.80.3-6.el5 set to be updated
---> Package kernel-xen.i686 0:2.6.18-52.el5 set to be updated
---> Package redhat-release.i386 0:5Server-5.1.0.2 set to be updated
---> Package net-snmp-libs.i386 1:5.3.1-19.el5 set to be updated
---> Package Deployment_Guide-en-US.noarch 0:5.1.0-11 set to be updated
---> Package kpartx.i386 0:0.4.7-12.el5 set to be updated
---> Package cups.i386 1:1.2.4-11.14.el5 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.26.el5 set to be updated
---> Package kernel.i686 0:2.6.18-52.el5 set to be updated
---> Package sos.noarch 0:1.7-9.1.el5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.6-104.el5 set to be updated
---> Package mesa-libGLU.i386 0:6.5.1-7.5.el5 set to be updated
---> Package gfs2-utils.i386 0:0.1.38-1.el5 set to be updated
---> Package strace.i386 0:4.5.16-1.el5.1 set to be updated
---> Package xorg-x11-drv-nv.i386 0:2.1.2-1.el5 set to be updated
---> Package redhat-release-notes.i386 0:5Server-9 set to be updated
---> Package audit-libs-python.i386 0:1.5.5-7.el5 set to be updated
---> Package audit.i386 0:1.5.5-7.el5 set to be updated
---> Package nss.i386 0:3.11.7-1.3.el5 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-19 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-17.el5 set to be updated
---> Package nfs-utils.i386 1:1.0.9-24.el5 set to be updated
---> Package cman.i386 0:2.0.73-1.el5 set to be updated
---> Package krb5-libs.i386 0:1.6.1-17.el5 set to be updated
---> Package mesa-libGL.i386 0:6.5.1-7.5.el5 set to be updated
---> Package nss-tools.i386 0:3.11.7-1.3.el5 set to be updated
---> Package xen-libs.i386 0:3.0.3-41.el5 set to be updated
---> Package kmod-gfs-xen.i686 0:0.1.19-6.el5 set to be updated
---> Package rpm-python.i386 0:4.4.2-47.el5 set to be updated
---> Package kernel-headers.i386 0:2.6.18-52.el5 set to be updated
---> Package rpm.i386 0:4.4.2-47.el5 set to be updated
---> Package audit-libs.i386 0:1.5.5-7.el5 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.26.el5 set to be updated
---> Package yum-rhn-plugin.noarch 0:0.5.2-3.el5 set to be updated
---> Package parted.i386 0:1.8.1-12.el5 set to be updated
---> Package gtk2.i386 0:2.10.4-19.el5 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-12.el5 set to be updated
---> Package ypbind.i386 3:1.19-8.el5 set to be updated
---> Package glx-utils.i386 0:6.5.1-7.5.el5 set to be updated
---> Package redhat-menus.noarch 0:6.7.8-2.el5 set to be updated
---> Package alsa-utils.i386 0:1.0.14-2.rc4.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-19 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-4.el5 set to be updated
---> Package kudzu.i386 0:1.2.57.1.15-1 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.55 set to be updated
---> Package hal.i386 0:0.5.8.1-25.el5 set to be updated
---> Package kexec-tools.i386 0:1.101-194.4.el5 set to be updated
--> Processing Dependency: xen-libs = 3.0.3-33.el5 for package: xen
--> Finished Dependency Resolution
--> Running transaction check
---> Package lvm2.i386 0:2.02.26-3.el5 set to be updated
---> Package system-config-kdump.noarch 0:1.0.12-1.el5 set to be updated
---> Package system-config-network-tui.noarch 0:1.3.99-2.el5 set to be updated
---> Package cups-libs.i386 1:1.2.4-11.14.el5 set to be updated
---> Package system-config-network.noarch 0:1.3.99-2.el5 set to be updated
---> Package initscripts.i386 0:8.45.17.EL-1 set to be updated
---> Package libpcap.i386 14:0.9.4-11.el5 set to be updated
---> Package kmod-gfs-xen.i686 0:0.1.16-5.2.6.18_8.1.10.el5 set to be erased
---> Package pm-utils.i386 0:0.99.3-6.el5.17 set to be updated
---> Package rpm-libs.i386 0:4.4.2-47.el5 set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.34.el5 set to be updated
---> Package tcpdump.i386 14:3.9.4-11.el5 set to be updated
---> Package crash.i386 0:4.0-4.6.1 set to be updated
---> Package kernel.i686 0:2.6.18-8.1.10.el5 set to be erased
---> Package xorg-x11-drv-mga.i386 0:1.4.2-6.el5 set to be updated
---> Package kmod-gfs.i686 0:0.1.19-6.el5 set to be updated
---> Package xorg-x11-drv-i810.i386 0:1.6.5-9.6.el5 set to be updated
---> Package mcstrans.i386 0:0.2.6-1.el5 set to be updated
---> Package popt.i386 0:1.10.2-47.el5 set to be updated
---> Package selinux-policy.noarch 0:2.4.6-104.el5 set to be updated
---> Package coolkey.i386 0:1.1.0-5.el5 set to be updated
---> Package hwdata.noarch 0:0.211-1 set to be updated
---> Package openais.i386 0:0.80.3-6.el5 set to be updated
---> Package kernel-xen.i686 0:2.6.18-52.el5 set to be updated
---> Package kmod-gfs.i686 0:0.1.16-5.2.6.18_8.1.10.el5 set to be erased
---> Package redhat-release.i386 0:5Server-5.1.0.2 set to be updated
---> Package net-snmp-libs.i386 1:5.3.1-19.el5 set to be updated
---> Package Deployment_Guide-en-US.noarch 0:5.1.0-11 set to be updated
---> Package kpartx.i386 0:0.4.7-12.el5 set to be updated
---> Package cups.i386 1:1.2.4-11.14.el5 set to be updated
---> Package xorg-x11-server-Xorg.i386 0:1.1.1-48.26.el5 set to be updated
---> Package kernel.i686 0:2.6.18-52.el5 set to be updated
---> Package sos.noarch 0:1.7-9.1.el5 set to be updated
---> Package selinux-policy-targeted.noarch 0:2.4.6-104.el5 set to be updated
---> Package mesa-libGLU.i386 0:6.5.1-7.5.el5 set to be updated
---> Package gfs2-utils.i386 0:0.1.38-1.el5 set to be updated
---> Package strace.i386 0:4.5.16-1.el5.1 set to be updated
---> Package xorg-x11-drv-nv.i386 0:2.1.2-1.el5 set to be updated
---> Package redhat-release-notes.i386 0:5Server-9 set to be updated
---> Package audit-libs-python.i386 0:1.5.5-7.el5 set to be updated
---> Package audit.i386 0:1.5.5-7.el5 set to be updated
---> Package kernel-xen.i686 0:2.6.18-8.1.10.el5 set to be erased
---> Package nss.i386 0:3.11.7-1.3.el5 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-19 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-17.el5 set to be updated
---> Package nfs-utils.i386 1:1.0.9-24.el5 set to be updated
---> Package cman.i386 0:2.0.73-1.el5 set to be updated
---> Package krb5-libs.i386 0:1.6.1-17.el5 set to be updated
---> Package mesa-libGL.i386 0:6.5.1-7.5.el5 set to be updated
---> Package nss-tools.i386 0:3.11.7-1.3.el5 set to be updated
---> Package xen-libs.i386 0:3.0.3-41.el5 set to be updated
---> Package kmod-gfs-xen.i686 0:0.1.19-6.el5 set to be updated
---> Package rpm-python.i386 0:4.4.2-47.el5 set to be updated
---> Package kernel-headers.i386 0:2.6.18-52.el5 set to be updated
---> Package rpm.i386 0:4.4.2-47.el5 set to be updated
---> Package audit-libs.i386 0:1.5.5-7.el5 set to be updated
---> Package xorg-x11-server-Xnest.i386 0:1.1.1-48.26.el5 set to be updated
---> Package yum-rhn-plugin.noarch 0:0.5.2-3.el5 set to be updated
---> Package parted.i386 0:1.8.1-12.el5 set to be updated
---> Package gtk2.i386 0:2.10.4-19.el5 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-12.el5 set to be updated
---> Package ypbind.i386 3:1.19-8.el5 set to be updated
---> Package glx-utils.i386 0:6.5.1-7.5.el5 set to be updated
---> Package redhat-menus.noarch 0:6.7.8-2.el5 set to be updated
---> Package alsa-utils.i386 0:1.0.14-2.rc4.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-19 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-4.el5 set to be updated
---> Package kudzu.i386 0:1.2.57.1.15-1 set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.55 set to be updated
---> Package hal.i386 0:0.5.8.1-25.el5 set to be updated
---> Package kexec-tools.i386 0:1.101-194.4.el5 set to be updated
--> Processing Dependency: xen-libs = 3.0.3-33.el5 for package: xen
--> Finished Dependency Resolution
Error: Missing Dependency: xen-libs = 3.0.3-33.el5 is needed by package xen


Expected results:
do update

Additional info:
[root@axqa01_1 ~]# wget 
http://archiv-server.gallien.atix/dist-mirrors/redhat/rhel/5/os/i386/RPMS/xen-libs-3.0.3-41.el5.i386.rpm
--16:45:13--  
http://archiv-server.gallien.atix/dist-mirrors/redhat/rhel/5/os/i386/RPMS/xen-libs-3.0.3-41.el5.i386.rpm
Resolving archiv-server.gallien.atix... 192.168.3.7
Connecting to archiv-server.gallien.atix|192.168.3.7|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 140306 (137K) [application/x-rpm]
Saving to: `xen-libs-3.0.3-41.el5.i386.rpm'

100%[======================================================================================================>] 
140,306     --.-K/s   in 0.02s

16:45:13 (8.17 MB/s) - `xen-libs-3.0.3-41.el5.i386.rpm' saved [140306/140306]

[root@axqa01_1 ~]# rpm -qpl xen-libs-3.0.3-41.el5.i386.rpm
/usr/lib/fs/ext2fs-lib
/usr/lib/fs/ext2fs-lib/fsimage.so
/usr/lib/fs/fat
/usr/lib/fs/fat/fsimage.so
/usr/lib/fs/iso9660
/usr/lib/fs/iso9660/fsimage.so
/usr/lib/fs/reiserfs
/usr/lib/fs/reiserfs/fsimage.so
/usr/lib/fs/ufs
/usr/lib/fs/ufs/fsimage.so
/usr/lib/libblktap.so.3.0
/usr/lib/libblktap.so.3.0.0
/usr/lib/libfsimage.so.1.0
/usr/lib/libfsimage.so.1.0.0
/usr/lib/libxenctrl.so.3.0
/usr/lib/libxenctrl.so.3.0.0
/usr/lib/libxenguest.so.3.0
/usr/lib/libxenguest.so.3.0.0
/usr/lib/libxenstore.so.3.0
/usr/lib/libxenstore.so.3.0.0
[root@axqa01_1 ~]# rpm -q --requires xen-libs-3.0.3-41.el5.i386.rpm
package xen-libs-3.0.3-41.el5.i386.rpm is not installed
[root@axqa01_1 ~]# rpm -q --requires xen-libs-3.0.3-41.el5.i386.rpm
[root@axqa01_1 ~]# rpm -qp --requires xen-libs-3.0.3-41.el5.i386.rpm
/sbin/ldconfig
/sbin/ldconfig
ld-linux.so.2
ld-linux.so.2(GLIBC_2.3)
libblktap.so.3.0
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.2)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.3)
libc.so.6(GLIBC_2.3.4)
libc.so.6(GLIBC_2.4)
libext2fs.so.2
libfsimage.so.1.0
libfsimage.so.1.0(libfsimage.so.1.0)
libpthread.so.0
libpthread.so.0(GLIBC_2.0)
libpthread.so.0(GLIBC_2.1)
libpthread.so.0(GLIBC_2.2)
libpthread.so.0(GLIBC_2.3.2)
libxenctrl.so.3.0
libxenguest.so.3.0
libxenstore.so.3.0
libz.so.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
[root@axqa01_1 ~]# wget 
http://archiv-server.gallien.atix/dist-mirrors/redhat/rhel/5/os/i386/RPMS/xen-3.0.3-41.el5.i386.rpm
--16:55:37--  
http://archiv-server.gallien.atix/dist-mirrors/redhat/rhel/5/os/i386/RPMS/xen-3.0.3-41.el5.i386.rpm
Resolving archiv-server.gallien.atix... 192.168.3.7
Connecting to archiv-server.gallien.atix|192.168.3.7|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
16:55:38 ERROR 404: Not Found.
Comment 1 Marc Grimme 2007-10-09 11:00:19 EDT
EBKAC, sorry. Please ignore and close.

Note You need to log in before you can comment on or make changes to this bug.