Bug 325011 - anaconda fails when one partition in /etc/fstab is encrypted
anaconda fails when one partition in /etc/fstab is encrypted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 10:56 EDT by Matěj Cepl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:55:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2007-10-09 10:56:38 EDT
Description of problem:
Following orders of my boss I have encrypted /home partition on my notebook.
Anaconda when finds partition in /etc/fstab which it cannot access announces the
fact and ends. I don't object to the fact that it cannot read encrypted
partitions (although, is it so complicated to run cryptsetup?), but it should
say something like "I cannot access partition /home. Should I just leave it alone?"

Version-Release number of selected component (if applicable):
anaconda for FC8test3

How reproducible:
100%

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
stops installation process

Expected results:
should get over the fact that I am not willing to share all secrets with her
(anaconda in Czech is female ;-)).

Additional info:
Comment 1 Jeremy Katz 2007-10-09 11:55:00 EDT
If we can't mount all the filesystems in the fstab, then   can't safely do an
upgrade.  Think about the case where someone has done something like made
/usr/share a symlink to /home/share because they needed the space or similar. 
The _only_ safe thing to do is to fail and have the user do it.  Especially as
in this case, it's because of something you manually configured.

Note You need to log in before you can comment on or make changes to this bug.