Bug 32525 - Installing on i586 processors
Installing on i586 processors
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 06:32 EST by redtux
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-18 11:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redtux 2001-03-21 06:32:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.8)
Gecko/20010215


Neither wolverine nor fisher install or run on i586 processors.
I have tried on a Intel P5 pentium 75 and a AMD K6/2

Neither would install

However RH7 installs perfectly on both

In fact on the K6/2 it will not boot from a fisher installation that was
working with a cyrix MII chip (i686)

Reproducible: Always
Steps to Reproduce:
1.Run though Installation process
2.
3.
	

Actual Results:  Signal 11

Expected Results:  Successful installation

This seems to be a problem with architecture
Comment 1 Michael Fulbright 2001-03-21 14:21:48 EST
Could you send the output of /proc/cpuinfo for one of the offending machines?

We have had success with K6/2 installs here.
Comment 2 redtux 2001-03-21 16:02:01 EST
output from the server at work (p5) is

processor
: 0
vendor_id
: GenuineIntel
cpu family	: 5
model
	: 2
model name	: Pentium 75 - 200
stepping
: 5
cpu MHz		: 90.001
fdiv_bug
: no
hlt_bug
	: no
sep_bug
	: no
f00f_bug
: yes
coma_bug
: no
fpu
	: yes
fpu_exception
: yes
cpuid level	: 1
wp
	: yes
flags
	: fpu vme de pse tsc msr mce cx8 apic
bogomips
: 179.40
Comment 3 redtux 2001-03-22 07:17:41 EST
CPU info for AMD K6/2

processor
: 0
vendor_id
: AuthenticAMD
cpu family	: 5
model
	: 8
model name	: AMD-K6(tm) 3D processor
stepping
: 12
cpu MHz		: 499.927
cache size	: 64 KB
fdiv_bug
: no
hlt_bug
	: no
sep_bug
	: no
f00f_bug
: no
coma_bug
: no
fpu
	: yes
fpu_exception
: yes
cpuid level	: 1
wp
	: yes
flags
	: fpu vme de pse tsc msr mce cx8 sep mtrr pge mmx 3dnow
bogomips
: 996.15


Comment 4 Michael Fulbright 2001-03-22 10:57:31 EST
I have confirmed internally that 3 of us are using K6/2 as our main machines
which installed w/o problem.

Is this a case of the CD not booting?  If so, have you tried booting from floppy
and installing from a CD?
Comment 5 redtux 2001-03-22 13:44:17 EST
TRied both methods of installin - boot disk and cdrom
Both fail at some point during the install -usually fairly late on
Comment 6 Michael Fulbright 2001-03-23 11:07:44 EST
Are you installing from a CD you burned?

What is the error you see when it dies?
Comment 7 redtux 2001-03-26 06:13:08 EST
Can't recall the exact error excepot that it refers to eip 0
Installation was from burned CD (by definition)
The same CD's install flawlessly on Cyrix MII and on an Athlon (both i686)
Comment 8 Michael Fulbright 2001-03-26 13:04:58 EST
If you could get us a copy of the error we will be able to help better.
Comment 9 redtux 2001-03-28 07:26:58 EST
Amd K6/2 further info

I installed RH7 - perfect
Updated to Wolverine - perfect
Then I tried fresh install of wolverine - crashed giving very little information

Signal 11 etc it is now safe to reboot your system etc
Comment 10 redtux 2001-03-29 14:01:31 EST
Not resolved - still crashes on fresh install
Comment 11 Brent Fox 2001-04-02 18:13:41 EDT
At what point does it crash and does it always crash at the same place?
Comment 12 Brent Fox 2001-04-18 11:01:07 EDT
This works on all of our i586 test machines.  I'm resolving as 'Works for me'.
Please try 7.1 (Seawolf) and reopen if the problem persists.

Note You need to log in before you can comment on or make changes to this bug.