Bug 32547 - rpm-4.0.2-6x breaks up2date, gnorpm, rhn_register
Summary: rpm-4.0.2-6x breaks up2date, gnorpm, rhn_register
Status: CLOSED DUPLICATE of bug 32301
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-21 17:53 UTC by Jan Carlson
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 17:53:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Carlson 2001-03-21 17:53:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


rpm-4.0.2-6x breaks up2date, gnorpm, rhn_register

RH6.2 with all current updates including rpm-4.0.2-6x.

# up2date
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio

# gnorpm
gnorpm: error in loading shared libraries: \
 /usr/lib/librpm.so.0: undefined symbol: fdio

# rhn_register
Traceback (innermost last):
  File "/usr/share/rhn/register/gui.py", line 32, in ?
    import rhnreg, hardware
  File "/usr/share/rhn/register/rhnreg.py", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio



Reproducible: Always
Steps to Reproduce:
1. Install rpm-4.0.2-6x and all other updates on RH6.2
2. Run up2date, gnorpm, or rhn_register
3. observe "/usr/lib/librpm.so.0: undefined symbol: fdio" every time.

Comment 1 Jeremy Katz 2001-03-21 18:49:21 UTC

*** This bug has been marked as a duplicate of 32301 ***


Note You need to log in before you can comment on or make changes to this bug.