Bug 32550 - query error stdout
query error stdout
Status: CLOSED DUPLICATE of bug 24314
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 13:30 EST by Jeff Voskamp
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 13:30:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Voskamp 2001-03-21 13:30:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686; Nav)


"rpm -q foo" now says "package foo is not installed" on stdout instead of
stderr
as of rpm-4.0.2-7x.

Reproducible: Always
Steps to Reproduce:
1.rpm -q foo >/tmp/stdout 2>/tmp/stderr
2.cat /tmp/stdout
3.cat /tmp/stderr
	

Actual Results:  [root@amnesia rpm-4.0.2]# rpm -q foo >/tmp/stdout
2>/tmp/stderr
[root@amnesia rpm-4.0.2]# cat /tmp/stdout
package foo is not installed
[root@amnesia rpm-4.0.2]# cat /tmp/stderr
[root@amnesia rpm-4.0.2]#  

Expected Results:  [root@amnesia rpm-4.0.2]# rpm -q foo >/tmp/stdout
2>/tmp/stderr
[root@amnesia rpm-4.0.2]# cat /tmp/stdout
[root@amnesia rpm-4.0.2]# cat /tmp/stderr
package foo is not installed
[root@amnesia rpm-4.0.2]#

This messes up some scripts I had for semi-automatic package updates since
uninstalled packages now produce output.
Comment 1 Jeff Johnson 2001-03-21 13:36:53 EST

*** This bug has been marked as a duplicate of 24314 ***

Note You need to log in before you can comment on or make changes to this bug.