Bug 325521 - oobase broken in latest update (2.2.1.18-2) against jre-1.6.0
oobase broken in latest update (2.2.1.18-2) against jre-1.6.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 16:21 EDT by A. Folger
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: F-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 03:24:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a small database file on which the latest update coughs and dies (27.65 KB, application/vnd.oasis.opendocument.database)
2007-10-09 16:21 EDT, A. Folger
no flags Details
screenshot of recovery dialog (61.17 KB, image/png)
2007-10-13 09:16 EDT, Stephen Haffly
no flags Details

  None (edit)
Description A. Folger 2007-10-09 16:21:39 EDT
Description of problem:
oobase is broken, can't open database files anymore

Version-Release number of selected component (if applicable):
2.2.1.18-2

How reproducible:
every time, by opening database made in previous release of oobase, such as
2.2.0-14.11, which I had used (the previously latest update).

Steps to Reproduce:
1. start oobase (click on icon or use terminal)
2. select "open existing database"
3. in the file open dialog, select an existing database
4. see how the application crashes and the gui disappears. It can only be
restarted after issueing kill -9  for all openoffice processes still running

Actual results:
program crashes, window disappears, but process is still living in the
background (though I don't know if one should call that "running", it is simply
preventing other instances of coming up).

Expected results:
database opens.

Additional info:
after downgrading back to 2.2.0-14.11, the database files could be opened and
used once again.
Comment 1 A. Folger 2007-10-09 16:21:39 EDT
Created attachment 221731 [details]
a small database file on which the latest update coughs and dies
Comment 2 Caolan McNamara 2007-10-11 03:00:25 EDT
Hmm, works for me. I can open that attachment in F-7 2.2.1-18.2.fc7 without any
problems :-(

What's the output of
rpm -q hsqldb
and what is listed for in openoffice.org
tools->options->openoffice.org->java 
is it "Free Software Foundation" ? or a different java implementation ?
Comment 3 A. Folger 2007-10-11 08:11:56 EDT
# rpm -q hsqldb
hsqldb-1.8.0.7-2jpp.2

However, I admit it. I sinned against the principles of the Great Stallman and
install only partially open (or should it be soon-to-be-partially-open) Sun
Java. It happens to be much more optimized, making oobase 10-20x faster (yes,
ten to twenty times).

# rpm -q jre
jre-1.6.0_01-fcs

Please do note that I use x86_64.
Comment 4 Stephen Haffly 2007-10-13 09:16:05 EDT
Created attachment 226371 [details]
screenshot of recovery dialog
Comment 5 Stephen Haffly 2007-10-13 09:27:07 EDT
My comment remarks didn't make it to the screenshot.

# rpm -qa openoffice.org-base
openoffice.org-base-2.2.1-18.2.fc7

# rpm -q hsqldb
hsqldb-1.8.0.7-2jpp.2

tools->options->openoffice.org->java Java version is Free Software Foundation 1.5.0

This database will open on my laptop running the 32 bit version of OOO, but not
the 64 bit version on my desktop.  On the 64 bit version, the Recover dialog
opens (screenshot).  If I select to recover, it just sits there and does nothing
until I finally kill it.

I will not attach the actual file as it contains passwords for various accounts
and web sites.
Comment 6 Caolan McNamara 2007-11-02 09:40:47 EDT
How about now with the latest update of 2.3.0-6.4.fc7 ?
Comment 7 Stephen Haffly 2007-11-02 18:06:39 EDT
I just tried it and it is now working.  Thanks.

Stephen
Comment 8 A. Folger 2007-11-14 03:09:17 EST
I was away and couldn't test. Meanwhile, I upgraded to fc8, where oobase 
works. Thanks for fixing.
Comment 9 Caolan McNamara 2007-11-14 03:24:10 EST
sounds good.

Note You need to log in before you can comment on or make changes to this bug.