Bug 32560 - kernel panic at end of install when rebooting server
Summary: kernel panic at end of install when rebooting server
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-21 20:12 UTC by Bryan Leopard
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 22:12:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bryan Leopard 2001-03-21 20:12:55 UTC
HW: ML350 1Ghz, 128MB ram, 9.1 Ultra3 HD, Integrated Adaptec controller
SW: RH 7.1 RC2

You get a kernel panic after copying files and the server starts to reboot.

rebooting system
Oops: 0000
cpu: 0
EIP: 0010: [<01af80fe>]
EFLAGS: 00010286
EAX: 00000000 EBX: c884db44 ECX: 4bfc5d12 EDX: 00000000
ESI: 00000000 EDI: 00000001 EBB: bfffffed8 ESP: c7ff1e90
ds: 0018 es: 0018 SS: 0018
Process linuxrc (PID: 8, stackpage=c7ff1000)
Stack .....
Calltrace .....

code: bad EIP value
VFS: Cannot open root device "" or 08:41
Please append a correct "root=" boot option
Kernel panic: VFS unable to mount root fs on 08:41

If you power off and on the server - linux boots up ok.
I have not seen this on other servers - maybe related to adaptec controller

Comment 1 prago 2001-03-21 22:05:30 UTC
In order to help our kernel team diagnose this problem more rapidly, we need
from you:

(1) the entire text printed on the console (including the details of "Stack..."
and "Calltrace...") saved to a file and posted as an attachment to this defect
(2) feed that text file to "ksymoops" and run it *on* the system that
experiences the Oops and post that output as an attachment to this defect
(3) add the output of the commands "/sbin/lspci" and "/sbin/lspci -v" as an
attachment to this defect

Thanks!

Comment 2 Glen Foster 2001-03-21 23:11:33 UTC
Re-assigning to kernel.

Comment 3 Arjan van de Ven 2001-03-21 23:17:03 UTC
This is a kernel panic because the kernel doesn't know where the filesystem is.
This is usually caused by incorrect installation (eg bad lilo or forgotten
initrd). The kernel is just the thing that gets to moan first.

Do the loading messages indicate the adaptec scsi driver is loaded _at all_?

Comment 4 Bryan Leopard 2001-03-22 22:12:15 UTC
This is apparently fixed in the QA0319 build.  We can no longer reproduce this.

Please close this issue.


Note You need to log in before you can comment on or make changes to this bug.