Bug 32574 - Any XFree86 xdm 4.x package fails to upgrade due to dir/symlink issue
Any XFree86 xdm 4.x package fails to upgrade due to dir/symlink issue
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 16:17 EST by Sherwin Levinson
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 11:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sherwin Levinson 2001-03-21 16:17:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


rpm -y XFree86-xdm-4.0.1-1.i386.rpm shows files missing, will not install.

Reproducible: Always
Steps to Reproduce:
Get XFree86-xdm-4.0.1-1.i386.rpm from CD or ftp.redhat.com, then:

rpm -U XFree86-xdm-4.0.1-1.i386.rpm


Actual Results:  $rpm -U XFree86-xdm-4.0.1-1.i386.rpm
warning: /etc/X11/xdm/Xresources saved as /etc/X11/xdm/Xresources.rpmorig
warning: /etc/X11/xdm/Xservers saved as /etc/X11/xdm/Xservers.rpmorig
warning: /etc/X11/xdm/Xwilling saved as /etc/X11/xdm/Xwilling.rpmorig
unpacking of archive failed on file /etc/X11/xdm/authdir: cpio: unlink 
failed -
Is a directory
$

I expect that most users use gdm or kdm instead of xdm, which is why 
nobody has noticed this yet.
Comment 1 Mike A. Harris 2001-03-22 15:27:22 EST
My guess is that the file you downloaded is corrupt.  Please
try downloading the file again, and if it still does not work, please
run the following command and cut and paste the results into
the bug report:

md5sum XFree86-xdm-4.0.1-1.i386.rpm

Most likely your download did not complete properly.
Comment 2 Sherwin Levinson 2001-03-22 16:30:20 EST
I think you must have missed that I said this happens with the file on the CD.
If I do "mount /dev/cdrom" with the first install CD in the drive, I get:

$rpm -y -p /mnt/cdrom/RedHat/RPMS/XFree86-xdm-4.0.1-1.i386.rpm
.M......   /etc/X11/xdm/authdir
missing    /etc/X11/xdm/chooser
missing    /etc/X11/xdm/pixmaps
missing    /etc/X11/xdm/pixmaps/XFree86.xpm
missing    /etc/X11/xdm/pixmaps/XFree86bw.xpm
missing    /etc/X11/xdm/xdm-config
missing    /etc/pam.d/xdm
missing    /usr/X11R6/bin/xdm
missing    /usr/X11R6/lib/X11/xdm
missing    /usr/X11R6/man/man1/xdm.1x.gz
missing    /var/lib/xdm
$

I downloaded a copy from ftp.redhat.com because the one on the CD was bad.
I get the same result with the downloaded copy, which cmp says is identical to 
the copy on the CD.

So it's not surprising that both yield the same md5sum: 
27ab6d2a0015b4369ec332463b5752ee
Comment 3 Mike A. Harris 2001-04-04 01:24:53 EDT
The command you are executing (rpm -y -p) compares what is stored in the
exact package you supply as an arg with what is installed on your hard disk.
Since that package is not installed, it is telling you so.  There is no
error, just you are misinterpreting the results of the command.

THe "Warning" messages you get, are just that - more "Info" than anything
wrong.  The failed authdir may be a problem replacing a dir with a symlink.
I'll look into it.

Was this a fresh install of Red Hat Linux 7.0, or an upgrade from a previous
version of Red Hat Linux, and if so, from what version?

Or are you just trying to install the XFree86 4.0.1 package from 7.0 in a
previous release?  Also, what version of rpm did you have installed when you
encountered this problem?
Comment 4 Sherwin Levinson 2001-04-05 11:53:49 EDT
Thank you for your detailed response and for clarifying "rpm -y -p" (I can't 
figure out where I got that from).

This was an upgrade install from 6.1;  I saved the output of "rpm -qa" from 
before the upgrade and it does not show any version of xdm as having been 
installed.

When I attempted to install XFree86-xdm I had rpm-4.0-4 installed.  I have 
since updated to rpm-4.0.2-7x.

Using "rpm -U XFree86-xdm-4.0.1-1.i386.rpm" with this new version, I still get:

  warning: /etc/X11/xdm/Xresources saved as /etc/X11/xdm/Xresources.rpmorig
  warning: /etc/X11/xdm/Xservers saved as /etc/X11/xdm/Xservers.rpmorig
  warning: /etc/X11/xdm/Xwilling saved as /etc/X11/xdm/Xwilling.rpmorig
  error: unpacking of archive failed on file /etc/X11/xdm/authdir: cpio: unlink 
failed - Is a directory

and "rpm -q XFree86-xdm" still reports "package XFree86-xdm is not installed"

Inspired by your comment that "The failed authdir may be a problem replacing a 
dir with a symlink," I looked at /etc/X11/xdm and decided it would be safe to 
remove that directory and all contents and sub-directories.  After removal, the 
install worked fine.

Digging further, XFree86-3.3.5-3 under 6.1 is what creates /etc/X11/xdm/authdir 
as a real directory.  Under 7.0, xinitrc-2.9.10-1.noarch.rpm creates some files 
in the /etc/X11/xdm directory, but as far as I can tell, nothing included with 
7.0 (other than xdm) actually creates a /etc/X11/xdm/authdir directory.

Conclusion:  under some upgrade installs (from 6.1 to 7.0 at least), 
installation of XFree86-xdm will fail if Xfree86 was installed under 6.1
Comment 5 Mike A. Harris 2001-04-08 06:49:39 EDT
This failure is indeed caused by a dir/symlink issue.  Problem fixed in
rawhide XFree86-4.0.3-7.

Thanks very much for your patience!

Note You need to log in before you can comment on or make changes to this bug.