Bug 32578 - Kernel oops on QA0319
Kernel oops on QA0319
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 17:38 EST by John A. Hull
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-13 12:01:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full oops info from screen (916 bytes, text/plain)
2001-03-28 12:01 EST, John A. Hull
no flags Details
Kickstart disk image (1.41 MB, image/png)
2001-04-06 17:28 EDT, John A. Hull
no flags Details
just kickstart image (12.31 KB, text/plain)
2001-04-13 11:58 EDT, Matt Wilson
no flags Details
just the ks.cfg (1.50 KB, text/plain)
2001-04-13 12:01 EDT, Matt Wilson
no flags Details

  None (edit)
Description John A. Hull 2001-03-21 17:38:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0; DigExt)


Access to Red Hat Beta not working, so filing this for Wolverine...

Kernel oops after "rebooting system" after hitting OK at the successful 
install screen.  Console states:
"Ooops:  0000
CPU:  0
EIP:  0010:[<85000001>]
Eflags:  00010286 ......
................................
Process  linuxrc
Code:  Bad
VFS:  Cannot open root device "" or 8:41
Please append a correct "root=" boot option
Kernel panic:  VFS:  Unable to mount root fs on 8:41"

Occuring on at least Dell PE 1300 and Dell PE 2400 after kickstart install.
**  Does not occur after CD install **

After reboot, everything is normal. 

Reproducible: Sometimes
Steps to Reproduce:
1. Perform kickstart install with QA0319
2. Hit OK at the successful installation screen
3. Kernel oops occurs
Comment 1 Glen Foster 2001-03-21 18:25:11 EST
Re-assigning to kernel
Comment 2 Glen Foster 2001-03-21 18:28:19 EST
John, you should have access to beta bugs, so I'm changing the product.
Comment 3 Arjan van de Ven 2001-03-23 14:56:08 EST
One question: If you type "noapic" on the LILO prompt, does it work then?
Comment 4 John A. Hull 2001-03-26 15:06:42 EST
Typing "noapic" at the LILO prompt has no effect.
Comment 5 Bill Nottingham 2001-03-27 14:46:16 EST
We need the full oops info, preferably run through ksymoops.
Comment 6 John A. Hull 2001-03-27 18:06:36 EST
Not sure what else you need. Output fomr ksymoops hard to get using install 
kernel. Let me know what else you need.

Kernel oops is occuring on 300,1300,2400 atleast.  Kernel oops occurs 
after network (not cdrom) install.  User hits Ok to reboot  and after 
"rebooting system" kernel oops's.  This particular oops is from a 300, 
kickstart installed w/ the qa0322 bootnet.img.
Comment 7 Matt Wilson 2001-03-27 19:01:03 EST
you need to copy at least the call trace down.
Comment 8 John A. Hull 2001-03-28 12:01:07 EST
Created attachment 13983 [details]
Full oops info from screen
Comment 9 Preston Brown 2001-04-03 09:56:57 EDT
john, your attachment appears empty.  Please try again.
Comment 10 Matt Domsch 2001-04-03 12:29:27 EDT
Oops: 0000
CPU:    0
EIP:    0010:[<6d6f7264>]
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010286
eax: 00000000   ebx: f8a76924   ecx: 2560f680   edx: 00000000
esi: 00000000   edi: 00000001   ebp: bffffeb8   esp: f7ff5e90
ds: 0018   es: 0018   ss: 0018
Process linuxrc (pid: 8, stackpage=f7ff5000)
Stack: c011b3f1 f8a76924 00000001 00000000 f7ff4000 00000000 00000072 c011b6f6 
       c0274888 00000001 00000000 c011095d f7ff5eec f78d5090 c0242000 c0172b3c 
       f7ff4000 00000000 c0242000 c0261520 f7ff5ef8 00000286 f7ff5ef8 c01106ce 
Call Trace: [<c011b3f1>] [<f8a76924>] [<c011b6f6>] [<c011095d>] [<c0172b3c>] 
[<c01106ce>] [<c0110600>] 
       [<c013c5d1>] [<c013cb25>] [<c012e9a5>] [<c0108ebf>] [<fee1dead>] 
Code:  Bad EIP value.

>>EIP; 6d6f7264 Before first symbol   <=====
Trace; c011b3f1 <notifier_chain_register+35/38>
Trace; f8a76924 <[cdrom].rodata.start+224/1b3f>
Trace; c011b6f6 <sys_reboot+8e/1c0>
Trace; c011095d <schedule+239/398>
Trace; c0172b3c <clear_buffer_attributes+c/78>
Trace; c01106ce <schedule_timeout+56/a0>
Trace; c0110600 <reschedule_idle+68/98>
Trace; c013c5d1 <sys_poll+61/2f8>
Trace; c013cb25 <locks_alloc_lock+35/48>
Trace; c012e9a5 <init_special_inode+25/b4>
Trace; c0108ebf <system_call+33/38>
Trace; fee1dead <END_OF_CODE+6381ab6/????>

Kernel panic: VFS: Unable to mount root fs on 08:41
Oops: 0000
CPU:    0
EIP:    0010:[<6d6f7264>]
EFLAGS: 00010286
eax: 00000000   ebx: f8a76924   ecx: 07772c7c   edx: 00000000
esi: 00000000   edi: 00000001   ebp: bffffeb8   esp: f7ff7e90
ds: 0018   es: 0018   ss: 0018
Process linuxrc (pid: 8, stackpage=f7ff7000)
Stack: c011b43d f8a76924 00000001 00000000 f7ff6000 00000000 00000072 c011b742 
       c0272a28 00000001 00000000 c011098d f7ff7eec f7956090 c0240000 c017280c 
       f7ff6000 00000000 c0240000 c025f520 f7ff7ef8 00000286 f7ff7ef8 c01106fe 
Call Trace: [<c011b43d>] [<f8a76924>] [<c011b742>] [<c011098d>] [<c017280c>] 
[<c01106fe>] [<c0110630>] 
       [<c013bea9>] [<c013c3fd>] [<c012e285>] [<c0108ebf>] [<fee1dead>] 
Code:  Bad EIP value.

>>EIP; 6d6f7264 Before first symbol   <=====
Trace; c011b43d <notifier_call_chain+1d/34>
Trace; f8a76924 <[cdrom].rodata.start+224/1b3f>
Trace; c011b742 <sys_reboot+da/1c0>
Trace; c011098d <schedule+269/398>
Trace; c017280c <con_put_char+1c/20>
Trace; c01106fe <schedule_timeout+86/a0>
Trace; c0110630 <process_timeout+0/48>
Trace; c013bea9 <do_select+1fd/214>
Trace; c013c3fd <sys_select+521/530>
Trace; c012e285 <sys_write+c1/cc>
Trace; c0108ebf <system_call+33/38>
Trace; fee1dead <END_OF_CODE+6381ab6/????>
Comment 11 Arjan van de Ven 2001-04-03 12:37:10 EDT
This looks like a device registering itself to be notified on reboot,
but forgetting to unregister before unloading the module.

What kind of hardware is used during the install ?
Comment 12 Matt Domsch 2001-04-03 12:55:17 EDT
System is a Dell PowerEdge 300 (aka 300SC), with an IDE disk and IDE CDROM, 1GB 
RAM, Intel PIIX4.  There's a 3Com 3c980c card, and a Lucent v.90 PCI modem 
at /dev/ttyS02.  I'm attaching an lspci of the system.

Linux version 2.4.2-0.1.40BOOT (root@porky.devel.redhat.com) (gcc version 2.96 
20000731 (Red Hat Linux 7.1 2.96-79)) #1 Tue Mar 27 14:50:37 EST 2001
BIOS-provided physical RAM map:
 BIOS-e820: 00000000000a0000 @ 0000000000000000 (usable)
 BIOS-e820: 0000000000010000 @ 00000000000f0000 (reserved)
 BIOS-e820: 000000003fefe000 @ 0000000000100000 (usable)
 BIOS-e820: 0000000000002000 @ 000000003fffe000 (reserved)
 BIOS-e820: 0000000000080000 @ 00000000fff80000 (reserved)
 BIOS-e820: 0000000000010000 @ 00000000fec00000 (reserved)
 BIOS-e820: 0000000000010000 @ 00000000fee00000 (reserved)
Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
On node 0 totalpages: 229376
zone(0): 4096 pages.
zone DMA has max 32 cached pages.
zone(1): 225280 pages.
zone lU"@lU"@ has max 1024 cached pages.
zone(2): 0 pages.
zone @V"@@V"@ has max 1 cached pages.
Kernel command line: ks=floppy console=ttyS0,115200 console=tty0 
initrd=initrd.img lang= devfs=nomount vga=788 BOOT_IMAGE=vmlinuz auto
Initializing CPU#0
Detected 795.912 MHz processor.
Console: colour dummy device 80x25
Calibrating delay loop... 1589.24 BogoMIPS
Memory: 899388k/917504k available (1193k kernel code, 17732k reserved, 84k 
data, 108k init, 0k highmem)
Dentry-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Buffer-cache hash table entries: 65536 (order: 6, 262144 bytes)
Page-cache hash table entries: 262144 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 65536 (order: 7, 524288 bytes)
CPU: Before vendor init, caps: 0383fbff 00000000 00000000, vendor = 0
CPU: L1 I cache: 16K, L1 D cache: 16K
CPU: L2 cache: 256K
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU: After vendor init, caps: 0383fbff 00000000 00000000 00000000
CPU: After generic, caps: 0383fbff 00000000 00000000 00000000
CPU: Common caps: 0383fbff 00000000 00000000 00000000
CPU: Intel Pentium III (Coppermine) stepping 06
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
Checking for popad bug... OK.
POSIX conformance testing by UNIFIX
PCI: PCI BIOS revision 2.10 entry at 0xfc84e, last bus=2
PCI: Using configuration type 1
PCI: Probing PCI hardware
Unknown bridge resource 0: assuming transparent
Unknown bridge resource 1: assuming transparent
Unknown bridge resource 2: assuming transparent
PCI: Using IRQ router PIIX [8086/7110] at 00:07.0
Limiting direct PCI/PCI transfers.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Starting kswapd v1.8
vesafb: framebuffer at 0xfc000000, mapped to 0xf8800000, size 2048k
vesafb: mode is 800x600x16, linelength=1600, pages=1
vesafb: protected mode interface info at c000:4ade
vesafb: scrolling: redraw
vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 100x37
fb0: VESA VGA frame buffer device
pty: 256 Unix98 ptys configured
block: queued sectors max/low 596914kB/465842kB, 1792 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4608K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PIIX4: IDE controller on PCI bus 00 dev 39
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:DMA, hdd:pio
hd1: C/H/S=0/0/0 from BIOS ignored
hda: WDC WD200BB-75AUA1, ATA DISK drive
hdc: CRD-8482B, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 39102336 sectors (20020 MB) w/2048KiB Cache, CHS=2434/255/63, UDMA(33)
Partition check:
 hda: hda1 hda2 < hda5 hda6 hda7 hda8 hda9 hda10 hda11 >
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
RAMDISK: Compressed image found at block 0
Freeing initrd memory: 754k freed
loop: loaded (max 8 devices)
Serial driver version 5.02 (2000-08-09) with MANY_PORTS SHARE_IRQ SERIAL_PCI 
enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
PCI: Found IRQ 10 for device 00:0d.0
ttyS02 at port 0xd800 (irq = 10) is a 16550A
md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
md.c: sizeof(mdp_super_t) = 4096
autodetecting RAID arrays
autorun ...
... autorun DONE.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 8192 buckets, 64Kbytes
TCP: Hash tables configured (established 262144 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
VFS: Mounted root (ext2 filesystem).
Comment 13 Matt Domsch 2001-04-03 12:55:46 EDT
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev 
03)
	Subsystem: Dell Computer Corporation: Unknown device 00de
	Flags: bus master, medium devsel, latency 32
	Memory at f4000000 (32-bit, prefetchable) [size=64M]
	Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03) 
(prog-if 00 [Normal decode])
	Flags: bus master, 66Mhz, medium devsel, latency 32
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
	I/O behind bridge: 0000e000-0000efff
	Memory behind bridge: fb000000-fdffffff
	Prefetchable memory behind bridge: f9000000-f9ffffff

00:02.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03) (prog-
if 00 [Normal decode])
	Flags: bus master, medium devsel, latency 32
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=32
	Capabilities: [dc] Power Management version 1

00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
	Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01) (prog-if 80 
[Master])
	Flags: bus master, medium devsel, latency 64
	I/O ports at ffa0 [size=16]

00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 
00 [UHCI])
	Flags: bus master, medium devsel, latency 32, IRQ 19
	I/O ports at dce0 [size=32]

00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
	Flags: medium devsel, IRQ 9

00:0d.0 Communication controller: Lucent Microelectronics Venus Modem (V90, 
56KFlex)
	Subsystem: Action Tec Electronics Inc: Unknown device 0480
	Flags: bus master, medium devsel, latency 0, IRQ 17
	Memory at fe000400 (32-bit, non-prefetchable) [size=256]
	I/O ports at d800 [size=256]
	I/O ports at d400 [size=256]
	I/O ports at dcd8 [size=8]
	Capabilities: [f8] Power Management version 2

00:10.0 Ethernet controller: 3Com Corporation 3c980-TX 10/100baseTX NIC [Python-
T] (rev 78)
	Subsystem: 3Com Corporation: Unknown device 1000
	Flags: bus master, medium devsel, latency 32, IRQ 19
	I/O ports at dc00 [size=128]
	Memory at fe000000 (32-bit, non-prefetchable) [size=128]
	Expansion ROM at fa000000 [disabled] [size=128K]
	Capabilities: [dc] Power Management version 2

01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC AGP (rev 
7a) (prog-if 00 [VGA])
	Subsystem: Dell Computer Corporation: Unknown device 00de
	Flags: bus master, stepping, medium devsel, latency 32
	Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
	I/O ports at ec00 [size=256]
	Memory at fbfff000 (32-bit, non-prefetchable) [size=4K]
	Expansion ROM at <unassigned> [disabled] [size=128K]
	Capabilities: [5c] Power Management version 1

Comment 14 Bill Nottingham 2001-04-03 15:15:26 EDT

*** This bug has been marked as a duplicate of 25318 ***
Comment 15 Matt Domsch 2001-04-03 17:50:55 EDT
My mistake, this is *not* a duplicate of 25318.
This one causes an oops on reboot, 25318 just hangs on reboot, no oops.
Comment 16 Matt Domsch 2001-04-06 14:54:42 EDT
Doug asks for our ks.cfg that we're using.
Comment 17 John A. Hull 2001-04-06 17:28:12 EDT
Created attachment 14829 [details]
Kickstart disk image
Comment 18 Matt Wilson 2001-04-13 11:58:41 EDT
Created attachment 15304 [details]
just kickstart image
Comment 19 Matt Wilson 2001-04-13 12:00:52 EDT
OOPS - the last attachment is the wrong one.
Comment 20 Matt Wilson 2001-04-13 12:01:30 EDT
Created attachment 15305 [details]
just the ks.cfg

Note You need to log in before you can comment on or make changes to this bug.