Bug 32579 - New RPM updates do not include rpm-python
New RPM updates do not include rpm-python
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 17:44 EST by Chris Siebenmann
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 17:44:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Siebenmann 2001-03-21 17:44:48 EST
The RPM 4.0.2-6x updates just issued recently do not include the
rpm-python RPM. Thus, anything relying on the Python support for
rpm is likely to break; at the best it will be using old shared
library linkages.

 I observe that RedHat could have seen this problem and others with
the rpm 4.0.2-6x upgrade if they (you) had bothered to version the RPM
shared libraries. If they had been versioned, RPM's dependancy checking
would have given you a nice list of things that depended on the old
libraries, so you would have had the list of 6.2 packages that needed
new versions of themselves made. Instead, you subverted the dependency
checking that is one of RPM's strong features, to the detriment of your
customers and users.
Comment 1 Jeff Johnson 2001-03-22 11:22:53 EST
Yup. The root cause was a typo in a GUI window, so any gain from bumping the
rpmlib
soname wouldn't have helped. In fact, the rpm-python package already has an
explicit
dependency on the rpm package exactly the same as what would have happened if a
new
rpmlib soname had been auto-magically detected by find-requires.

This isn't an argument for not changing the rpmlib soname (that certainly needs
doing as well),
only an observation. Yes there will be an errata for gnorpm, rpmfind, et al to
handle the
lack of change in the rpmlib soname, that's a different issue.

rpm-python-4.0.2-6x is now  available as part of the re-released errata.

Note You need to log in before you can comment on or make changes to this bug.