Bug 326061 - Bad installation disk initialization/selection process design, design and functionality bugs found.
Bad installation disk initialization/selection process design, design and fun...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 06:07 EDT by c.h.
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 15:27:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description c.h. 2007-10-10 06:07:38 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. e.g. Set up two totally blank HDDs, begin Fedora 8T3 8.92 graphical install.
2. See dialogs saying that SDA, SDB are uninitialized and may be initialized for
use with Fedora.  Initially answer 'NO' to the initialization dialogs for SDA, SDB.
3. Proceed to next 'choose/prepare your installations disks & partition layouts'
screen, expecting to see the full list of disk devices in the system along with
information on their capacities, model numbers, logical device name assignments,
et. al.  Expect to have the option to choose any drives to be initialized at
*that* screen when information is available about *which* 
hardware device 'sda' or 'sdb' really refers to.  Expect to be able to
reconsider my previous 'uninformational dialog box' choices to not initialize
sda,sdb and in fact choose to initialize use them if desired.

  
Actual results:
When one continues to the main partitioning/disk device selection screen
in this circumstance, no disk devices at all were present in the lists of
devices.  It was not apparent that there was *any* way from this screen to
even note the presence of those disk drives, nor did there seem to be any way
offered to reconsider the 'I'd like to initialize one of the previously
mentioned blank attached disks' choice.   

Indeed (this is SURELY a bug even if the other design choices are debatably
'as intended'), if you then use the BACK button to return to the previous
installation step, expecting to go BACK to the dialog(s) asking whether you
wanted to initialize the blank drives, or perhaps BACK to the menu state
BEFORE those dialogs popped up (thus creating an opportunity to go FORWARD
and change one's mind about disk initialization), you'll be taken 'BACK'
to one previous menu, but continuing on from there there is NO option to
reconsider the disks to be initialized, the dialog boxes are never
again shown as one proceeds forward from the menu that originally preceded
their appearance.  Apparently one has to reboot to re-run the installer
to get the opportunity to access/initialize/use those previously unselected
disks.


Expected results:
IMHO one should never be asked to choose a disk / partition for installation
or initialization / partitioning / any other potentially destructive process
unless it's simultaneously presented in a crystal clear fashion exactly
WHAT that device / partition physically and logically refers to also in the
context of all other detected drives / partitions in the machine.
e.g. 'sda' COULD be anything from one of my card readers, either one of the
two PATA disks, other USB attached mass storage drives, etc.  

I'd respectfully suggest it'd be more useful to present more contextual
information such as:
'The logical disk sda is a PATA drive on the system's ICH9 interface in
the primary master position, it is a Western Digital WD1200JB-RTL model,
with hardware serial number 3874, its capacity is 120GBy, there are no
detected partition(s) of any known type on it.  
...
The logical disk sdb is a PATA drive on the system's ICH9 interface in
the primary slave position, it is a Maxtor model, STM305004,
with hardware serial number 1234, its capacity is 500GBy, there are
detected partition(s) on it: sda1: 40GBy, FAT32, Label "Sandbox1",
...etc...etc..
THEN the user may give an informed decision as to which drives to
initialize / partition / repartition, etc.  Otherwise you're just guessing
with no correlative information at all as to which drive(s) or partition(s)
you're being asked to initialize or operate on.

IMHO it should also be clearly stated WHEN such initialization processes would
occur; from the wording of the dialog boxes it appeared as if deciding 
'YES, initialize this drive sda' could / would cause immediate data loss,
though that was unexpected since I had the notion that the installer would
let one choose any initialization / partitioning / installation choices
at all with no data loss up until the point when one commits to those
actions by proceeding affirmatively to CONTINUE PAST the main partitioning /
installation choices menus to actually begin the installation.

There simply isn't enough available information in the context of those
dialog boxes for the user to make any safe / sure decision about how to
proceed other than indicating 'NO', but if one does that, it's quite impossible
to reconsider or even be presented with information about the physical
and logical devices and device names present in the system.

I consider this a high priority installation preventing problem 
since the ambiguity and contextual absence results in confusion and either 
on one hand in data loss from a mistaken "Yes initialize that logical 
device name!" decision, or in complete inability to install Fedora (short of 
a reboot into the installer once again) if one answers 'NO' expecting 
the option to go either  FORWARD or BACK to change one's mind given better
information.


Additional info:

I tagged this as X86_64, though AFAIK it'd likely (but I didn't verify this)
be the same problem on any x86 / i[n]86 type system, and perhaps for other
architectures as well.
Comment 1 Jeremy Katz 2007-10-10 15:27:20 EDT
Once you've said to ignore a disk, we ignore it forever.  This is due to
requests from people who would go back and forth and get bothered by being asked
many times about it.  We're looking at making some more dramatic changes to how
partitioning is done in a future release and will look at resolving this then.

Note You need to log in before you can comment on or make changes to this bug.