Bug 326081 - selinux prevents vmplayer to load libview.so.2
selinux prevents vmplayer to load libview.so.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 06:25 EDT by Daniel Rogowski
Modified: 2008-01-30 14:06 EST (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 14:06:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
AVC messages (1002 bytes, text/plain)
2007-10-10 10:01 EDT, Daniel Rogowski
no flags Details

  None (edit)
Description Daniel Rogowski 2007-10-10 06:25:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.7 (like Gecko)

Description of problem:
I tried to execute the vmplayer. It gave the following error:
"/usr/lib/vmware/bin/vmplayer: error while loading shared libraries: 
libview.so.2: cannot open shared object file: No such file or directory"

After that I deactivated SELinux, tried again and it worked. I didn't change 
anything else.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.6.4-46.fc7

How reproducible:
Always


Steps to Reproduce:
(0. Activate SELinux)
1. Download the VMware-player-2.0.1-55017.i386.rpm
2. Install it: "yum localinstall VMware-player-2.0.1-55017.i386.rpm" (maybe 
you have to deactivate "gpgcheck")
3. Run the configurator: "/usr/bin/vmware-config.pl" and use default options
4. Run the player: "vmplayer"

Actual Results:
It didn't run and gave the following error msg instead:
/usr/lib/vmware/bin/vmplayer: error while loading shared libraries: 
libview.so.2: cannot open shared object file: No such file or directory

Expected Results:
The vmplayer should have run.

Additional info:
Comment 1 Daniel Walsh 2007-10-10 09:24:19 EDT
Did you see any avc messages in /var/log/audit/audit.log or /var/log/messages?

You can probably 

chcon -t textrel_shlib_t PATHTOSHLIBS

To get it to work with SELinux.

This is caused because vmware has built their libraries incorrectly.  Please
attach the AVC messages and I will fix the labeling.
Comment 2 Daniel Rogowski 2007-10-10 10:01:54 EDT
Created attachment 222501 [details]
AVC messages
Comment 3 Daniel Rogowski 2007-10-10 10:07:45 EDT
"chcon -t textrel_shlib_t /usr/lib/vmware/lib/*" didn't change anything.
Comment 4 Daniel Walsh 2007-10-11 09:27:31 EDT
YOu can turn off execstack protection with 

setsebool -P allow_execstack=1

Comment 5 Daniel Rogowski 2007-10-12 03:27:39 EDT
Ok, it works. But it's not the best thing to do, is it?
Comment 6 Daniel Walsh 2007-10-12 08:20:02 EDT
Actually a better fix would be to 

chcon -t vmware_exec_t /usr/lib/vmware/bin/vmplayer
Comment 7 Daniel Walsh 2007-10-12 08:54:08 EDT
Fixed in selinux-policy-2.6.4-49
Comment 8 Daniel Walsh 2008-01-30 14:06:41 EST
Bulk closing a old selinux policy bugs that were in the modified state.  If the
bug is still not fixed.  Please reopen.

Note You need to log in before you can comment on or make changes to this bug.