Bug 326331 - no .rpmmacros throws exception
no .rpmmacros throws exception
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse-rpm-editor (Show other bugs)
8
All All
medium Severity medium
: ---
: ---
Assigned To: Alphonse Van Assche
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 09:30 EDT by Andrew Overholt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 11:53:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2007-10-10 09:30:15 EDT
I'm running F8test3's Developer Live DVD and after creating and editing a specfile, I
get
the following in my log:

!ENTRY org.eclipse.linuxtools.rpm.ui.editor 4 0 2007-10-10
13:23:25.293
!MESSAGE
Unexpected Exception
!STACK 0
java.io.FileNotFoundException: /home/fedora/.rpmmacros
(No
such file or directory)
        at java.io.FileInputStream.open(Native Method)
  
   
 at java.io.FileInputStream.<init>(FileInputStream.java:138)
        at java.io.FileInputStream.<init>(FileInputStream.java:97)


      at org.eclipse.linuxtools.rpm.ui.editor.RpmMacroProposalsList.addMacroToMap(RpmMacroProposalsList.java:72)


      at org.eclipse.linuxtools.rpm.ui.editor.RpmMacroProposalsList.buildMacroList(RpmMacroProposalsList.java:57)


      at org.eclipse.linuxtools.rpm.ui.editor.RpmMacroProposalsList.<init>(RpmMacroProposalsList.java:41)


      at org.eclipse.linuxtools.rpm.ui.editor.Activator.getRpmMacroList(Activator.java:109)


      at org.eclipse.linuxtools.rpm.ui.editor.SpecfileCompletionProcessor.computeRpmMacroProposals(SpecfileCompletionProcessor.java:201)


      at org.eclipse.linuxtools.rpm.ui.editor.SpecfileCompletionProcessor.computeCompletionProposals(SpecfileCompletionProcessor.java:112)


      at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompletionProposals(ContentAssistant.java:1759)


      at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeProposals(CompletionProposalPopup.java:478)


      at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeFilteredProposals(CompletionProposalPopup.java:1330)


      at org.eclipse.jface.text.contentassist.CompletionProposalPopup.access$4(CompletionProposalPopup.java:1281)


      at org.eclipse.jface.text.contentassist.CompletionProposalPopup$1.run(CompletionProposalPopup.java:302)


      at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
        at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)


      at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3296)
       
at
org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2974)
        at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2389)


      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2353)
        at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2219)


      at org.eclipse.ui.internal.Workbench$4.run(Workbench.java:466)
        at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:289)


      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:461)


      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      

at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:106)


      at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:153)


      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:106)


      at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:76)


      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)


      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)


      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)


      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)


      at java.lang.reflect.Method.invoke(Method.java:623)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:504)


      at org.eclipse.equinox.launcher.Main.basicRun(Main.java:443)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1169)
Comment 1 Alphonse Van Assche 2007-10-12 04:20:37 EDT
Hello Andrew,

How do you prefer fix that problem, 1) check if the file is present before
adding it to the macro file list, 2) if the file is not found just run the
appropriate command to create it.

Normally I should find time to implement that this w-e.

Cheers,

Comment 2 Andrew Overholt 2007-10-12 11:53:50 EDT
Hi Alphonse,

I think 1) is best.  Thanks!

I've actually moved this upstream since that's where it should be:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=206160

Andrew

Note You need to log in before you can comment on or make changes to this bug.