Bug 32698 - Error importing librpm.so.0 in up2date-2.1.7 with rpm-4.0.2
Error importing librpm.so.0 in up2date-2.1.7 with rpm-4.0.2
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
: 32301 32657 34210 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-22 09:20 EST by Need Real Name
Modified: 2015-01-07 18:44 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 09:20:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-22 09:20:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.18 i686)


After installing new rpm-4.0.2, running up2date-2.1.7 leads to the
following message:
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio


Reproducible: Always
Steps to Reproduce:
1.up2date
2.
3.
	

Actual Results:  Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio


Expected Results:  Update agent window should appear.
Comment 1 Preston Brown 2001-03-22 11:29:56 EST
The version of RPM on the network a few days ago did not depend on a new 
version of rpm-python.  It should have.  Because of this, you will need to 
retrieve rpm-python manually with ftp to correct the issue, and then 
everything will work again.  The packages have been corrected on the web site.

Go to ftp://updates.redhat.com/6.2/i386
and get rpm-python-4.0.2-6x.i386.rpm.
Comment 2 Preston Brown 2001-03-22 11:30:35 EST
*** Bug 32657 has been marked as a duplicate of this bug. ***
Comment 3 Preston Brown 2001-03-22 11:54:07 EST
*** Bug 32301 has been marked as a duplicate of this bug. ***
Comment 4 Jacob Killian 2001-03-22 15:53:35 EST
Um...pardon my ignorance, but if rpm is broken, how am I supposed to fix it by
installing another rpm?
Comment 5 R.K.Aa. 2001-03-26 09:44:04 EST
i installed the rpm-python package before upgrading to rpm 4.0.2 and rpm
fromcommandline works just fine.
But gnorpm and others are still as broken. Bug 33085 is still open on the issue.
Comment 6 Preston Brown 2001-04-03 11:43:01 EDT
*** Bug 34210 has been marked as a duplicate of this bug. ***
Comment 7 Abdullah 2003-11-05 14:09:06 EST
Hi

I had uninstalled cdparanoia-libs-alpha9.8-15, following it 
immediately i started to get errors using rpm -q, or rpm -a commands 
and also using the up2date command.

Is there any solution cause now i cant even download and install the 
rpm manager, cause my rpm commands show /bin/rpm doesnt exist.

Here are the errors,

[root@www init.d]# rpm -aq | more
bash: /bin/rpm: No such file or directory

[root@www init.d]# up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 11, in ?
    import rpm
ImportError: librpm-4.2.so: cannot open shared object file: No such 
file or directory

Thanks
Abdullah
Comment 8 Abdullah 2003-11-05 14:09:31 EST
Hi

I had uninstalled cdparanoia-libs-alpha9.8-15, following it 
immediately i started to get errors using rpm -q, or rpm -a commands 
and also using the up2date command.

Is there any solution cause now i cant even download and install the 
rpm manager, cause my rpm commands show /bin/rpm doesnt exist.

Here are the errors,

[root@www init.d]# rpm -aq | more
bash: /bin/rpm: No such file or directory

[root@www init.d]# up2date -u
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 11, in ?
    import rpm
ImportError: librpm-4.2.so: cannot open shared object file: No such 
file or directory

Thanks
Abdullah

Note You need to log in before you can comment on or make changes to this bug.