Bug 327491 - Internal server error
Internal server error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Clifford Perry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 07:06 EDT by Aldo Mantovani
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 09:54:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aldo Mantovani 2007-10-11 07:06:26 EDT
Description of problem:

% cat /var/log/up2date
[Thu Oct 11 12:48:11 2007] up2date updating login info
[Thu Oct 11 12:48:11 2007] up2date logging into up2date server
[Thu Oct 11 12:48:13 2007] up2date successfully retrieved authentication token
from up2date server
[Thu Oct 11 12:48:13 2007] up2date Updating package profile
[Thu Oct 11 12:48:49 2007] up2date Error communicating with server. The message was:

Error Message:
    Unknown package arch found
Error Class Code: 45
Error Class Info: 
     Invalid architecture.

     The architecture of the package is not supported by Red Hat Network
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

[Thu Oct 11 12:48:49 2007] up2date 
Traceback (most recent call last):
  File "/usr/sbin/rhn-profile-sync", line 54, in ?
    cli.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn-profile-sync", line 42, in main
    rhnPackageInfo.updatePackageProfile()
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 27, in
updatePackageProfile
    rpmUtils.getInstalledPackageList(getArch=1))
  File "/usr/share/rhn/up2date_client/rhnserver.py", line 52, in __call__
    raise self.__exception_from_fault(f)
up2date_client.up2dateErrors.CommunicationError: Error communicating with
server. The message was:

Error Message:
    Unknown package arch found
Error Class Code: 45
Error Class Info: 
     Invalid architecture.

     The architecture of the package is not supported by Red Hat Network
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1./usr/sbin/rhn-profile-sync -v
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Red Hat Bugzilla 2007-10-25 20:53:41 EDT
User jslagle@redhat.com's account has been closed
Comment 2 Clifford Perry 2007-11-02 09:54:14 EDT
This is almost certainly not a bug. Most likely the client system has installed
within its packages an invalid arch, such as em64t. 

RHN Hosted is throwing an error letting you know of this. 

NOTABUG. 

But, please do re-open if you feel your installed RPM package manifest does not
include any invalid package archs. 

Thanks,
Cliff. 

Note You need to log in before you can comment on or make changes to this bug.