This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 327531 - gstreamer-plugins couldnt rebuild on s390 and s390x
gstreamer-plugins couldnt rebuild on s390 and s390x
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gstreamer-plugins (Show other bugs)
4.5
All Linux
low Severity low
: ---
: ---
Assigned To: Monty
:
: 699536 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 07:50 EDT by Jay Turner
Modified: 2015-01-07 19:16 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:55:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2007-10-11 07:50:31 EDT
Description of problem:
gstreamer-plugins-0.8.5-1.EL.1.*.rpm is built for all architectures. There is
problem with arch s390*. It fails when I am starting tps-srpms on arch s390*.
Its because of dependencies. Packages libdv-devel and  libraw1394-devel are
missing. But these packages are NOT available for arch s390*.


Version-Release number of selected component (if applicable):
gstreamer-plugins-0.8.5-1.EL.1.*.rpm

How reproducible:
always

Steps to Reproduce:
1. rebuilding gstreamer-plugins
  
Actual results:
it fails, missing dependencies on libdv-devel and libraw1394-devel

Expected results:
no dependencies on libdv-devel and libraw1394-devel with arch s390 and s390x, or
gstreamer-plugins shouldn't be built for arch s390 and s390x.
Spec file should be changed.

Additional info:
Comment 1 Red Hat Bugzilla 2007-10-31 21:30:56 EDT
User psklenar@redhat.com's account has been closed
Comment 2 Jay Turner 2009-10-26 10:27:04 EDT
Looks like this is partially resolved with 0.8.5-1.EL.2:

- the BuildRequires on libdv-devel is "%ifnarch s390 s390x"
- that still leaves the BuildRequires on libraw1394-devel, a package which is not available on s390 and s390x:

$ pwd
/mnt/engarchive2/released/RHEL-4/U8/AS
[jkt@cobalt AS]$ find . -name "libraw1394-devel*" -print
./i386/tree/RedHat/RPMS/libraw1394-devel-0.10.1-3.i386.rpm
./ia64/tree/RedHat/RPMS/libraw1394-devel-0.10.1-3.ia64.rpm
./ppc/tree/RedHat/RPMS/libraw1394-devel-0.10.1-3.ppc.rpm
./x86_64/tree/RedHat/RPMS/libraw1394-devel-0.10.1-3.x86_64.rpm
Comment 3 Tomas Hoger 2011-08-16 08:25:50 EDT
*** Bug 699536 has been marked as a duplicate of this bug. ***
Comment 4 John W. Lockhart 2011-08-16 12:55:17 EDT
Note that bug 699536 had a proposed patch attached to it.
Comment 5 Jiri Pallich 2012-06-20 11:55:03 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.