Bug 32759 - up2date error with new rpm packages
up2date error with new rpm packages
Status: CLOSED DUPLICATE of bug 32301
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-22 21:13 EST by Roy W. Reter
Modified: 2015-01-07 18:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 13:07:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy W. Reter 2001-03-22 21:13:11 EST
When all the latest updates have been applied to an Intel RH 6.2 system (even the new db3 and latest rpm packages) and you try to run 
up2date either in X or from the command line will produce the following error:

[root@machine /root]# up2date -u -i 
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio
Comment 1 Roy W. Reter 2001-03-23 13:07:09 EST
Just upgraded rpm-python-4.0.2-6x and this seems to have fixed the error.  Perhaps a dependency check was missed when using up2date.
Comment 2 Preston Brown 2001-03-26 18:42:34 EST
please search for duplicates before posting bugs.


*** This bug has been marked as a duplicate of 32301 ***

Note You need to log in before you can comment on or make changes to this bug.