Bug 32805 - XFree86 hangs when executed
XFree86 hangs when executed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 02:05 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 02:05:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-23 02:05:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


I have installed wolverine clean - formatted appropriate partitions.
When I run XFree86 from X terminal the screen hangs. I can move the mouse 
cursor. I can see the process running from a ssh client. When I kill the 
xfree process I can nolonger move mouse - for all intents and purposes the 
machine is hung and requires a hardware reset.

Reproducible: Always
Steps to Reproduce:
1.login (root)
2.XFree86
3.
	

Actual Results:  grey background with big black cross

Expected Results:  More than this

Intel Pentium Pro 200
Virge DX 4MB
Digital PCXBV-PG 14" monitor at 800x600
PS/2 mouse
Comment 1 Mike A. Harris 2001-03-23 04:32:19 EST
Sounds like you are new to Linux and are not using X windows correctly.
You don't execute "XFree86" from an xterminal.  XFree86 is the name of the
implementation of X11.  It is also the name of the server binary which you
do not execute by hand. To start X windows, you either boot your system into
runlevel 3, then log in and run "startx", or you boot your system into
runlevel 5 and log in using gdm/kdm/xdm.

If you actually log in, and run the command "XFree86", you will get exactly
what you told it to do - to execute the raw X server binary with no
applications, no desktop, nothing.  You'll end up with  black and white
herringbone pattern on the screen with an "X" mouse pointer, and that is it.
This is correct behaviour and not a bug.  You might want to read the
Red Hat Linux users guide to get up to speed.  There are also HOWTO documents
in /usr/share/doc/HOWTO that are good for the beginner as well.

Good luck, and have fun.

Note You need to log in before you can comment on or make changes to this bug.