Bug 32806 - Compaq Proliant 5500, 1 CPU, /lib/liobc.so.6: undefined symbol: ,
Compaq Proliant 5500, 1 CPU, /lib/liobc.so.6: undefined symbol: ,
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-23 04:01 EST by gerald.ehritz
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-26 11:27:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description gerald.ehritz 2001-03-23 04:01:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)

Installing Wolverine on a Compaq Proliant 5500 with 1 CPU, 2 GB Memory, 2
Smart Array 3200 Controller, stops after loading the drivers for Smart
Array and Onboard SCSI with

/usr/bin/python: error while loading shared libraries: /lib/libc.so.6: 
undefined symbol: , Version GLIBC_2.1
install exited abnormally

Reproducible: Always
Steps to Reproduce:
1.Boot from CD
2.choose text
3.after loading the scsi drivers system is halted.

Actual Results:  system needs reboot.

Expected Results:  system should boot to install it.

Configuration works with RH 7.0
I used this boot cd on 2 other systems (1 laptop, 1 normal pc) and it
worked; maybe something wrong in the multiprocessor setups?
Comment 1 Michael Fulbright 2001-03-23 10:55:04 EST
Matt any ideas?
Comment 2 Matt Wilson 2001-03-23 11:33:21 EST
does GUI work (it shouldn't, with this error)
Comment 3 gerald.ehritz 2001-03-26 05:55:47 EST
Lot more testing with a new cdrom and a boot floppy gives following results:
1.) boot in text mode ( with or without mem=900M )exits with signal 4;
    Alt+F4: <6> cpqarray looks good
	    <6> sym53c876 looks good
	    <7> ISO 9660 Extensions: RRIP_1991A
	    <4> Unable to identify CD-ROM format

2.) boot in graphics mode ( with or without mem=900M ) exits with signal 11, but
also with missing libc.so.6;
     Alt+F4: <6> cpqarray looks good
	     <6> sym53c876 looks good
	     <7> ISO 9660 Extensions: RRIP_1991A
	     <4> Unable to identify CD-ROM format
	     <6> attempt to access beyond end of device
	     <6> 07:00: rw=0,want=1634948585, limit=101382

Doing the same with a RedHat 7.0 boot cd works without a problem.
System has 2 GB Memory, Bios Setup has Linux as target OS.
Comment 4 Matt Wilson 2001-03-26 10:08:36 EST
I'm betting this is corruption when reading from the CD.  Is the CD-ROM drive
attached to an IDE bus?
Comment 5 gerald.ehritz 2001-03-26 10:48:22 EST
I think you are right; this is a 5500 Xeon and it uses IDE for its cdrom.
I tested an old Proliant 1500 ( SCSI cdrom ) and it boots the CD fine.
Comment 6 Matt Wilson 2001-03-26 11:27:36 EST
if this was a serverworks chipset machine, we've gone back to the generic
(slower) ide code for just these problems.  Assigning to kernel for
Comment 7 Arjan van de Ven 2001-04-07 16:30:28 EDT
Serverworks IDE was beaten into working a while a go...
Comment 8 Glen Bodie 2001-06-16 12:22:52 EDT
What was the resolution?

I may have the same thing in RH7.1 on a P2-233, 1 CPU, SCSI CD-ROM.  It 
detected the bootable CD, started the installer and had exactly the same error 
whether I selected GUI or text install mode.  After it loaded the AIC driver, 
started anaconda, it flipped out with:
/usr/bin/python - error loading shared library /lib/libc.so.6 - unexpected PLT 
reloc type 0x00

What's the fix?
Comment 9 gerald.ehritz 2001-06-18 03:22:31 EDT
Tested the official RedHat 7.1 Professional Server today. It does not work. Same 
error as in beta version.
7.1 is installable if i use a nfs mounted directory! After install using the cd
drive works.
Comment 10 Arjan van de Ven 2001-06-18 04:06:23 EDT
gerald.ehritz@hl-ag.com: try passing "ide=nodma" to the kernel-commandline (eg
the syslinux prompt)

glen@glenbodie.com: sounds like a completely different bug, please file a
separate one
Comment 11 gerald.ehritz 2001-06-18 08:53:16 EDT
This fixewd the problem, it works now.

Note You need to log in before you can comment on or make changes to this bug.