Bug 328141 - Yum ambiguity
Yum ambiguity
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 14:57 EDT by Luya Tshimbalanga
Modified: 2014-01-21 17:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-17 08:56:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use rpm's own messages for rpm_check_debug output (1.69 KB, patch)
2007-10-25 08:09 EDT, Panu Matilainen
no flags Details | Diff

  None (edit)
Description Luya Tshimbalanga 2007-10-11 14:57:26 EDT
Description of problem:
Two package of the same name


Version-Release number of selected component (if applicable):
 3.2.5-1.fc7  

How reproducible:
Always
Steps to Reproduce:
1. Update a package (in this example, Gimp from development version)
2.
3.
  
Actual results:
Two identical packages without a clear way of differentiation.
i386? x86-64?

Expected results:
Yum should specify the architecture of these identical package

Additional info:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 gimp                    x86_64     2:2.4.0-0.rc3.1.fc8  development        13 M
Updating for dependencies:
 evince                  x86_64     2.20.0-3.fc8     development       1.2 M
 gimp-libs               x86_64     2:2.4.0-0.rc3.1.fc8  development       574 k
 glibc                   x86_64     2.6.90-18        development       4.8 M
 glibc                   i686       2.6.90-18        development       5.4 M
 glibc-common            x86_64     2.6.90-18        development        21 M
 glibc-devel             x86_64     2.6.90-18        development       2.4 M
 glibc-headers           x86_64     2.6.90-18        development       598 k
 koffice-core            x86_64     1.6.3-11.fc8     development       1.7 M
 koffice-filters         x86_64     1.6.3-11.fc8     development       2.1 M
 koffice-kexi            x86_64     1.6.3-11.fc8     development       3.4 M
 koffice-krita           x86_64     1.6.3-11.fc8     development        31 M
 koffice-libs            x86_64     1.6.3-11.fc8     development       4.6 M
 poppler                 x86_64     0.6-1.fc8        development       3.1 M
 poppler-qt              x86_64     0.6-1.fc8        development        29 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      15 Package(s)         
Remove       0 Package(s)         

Total download size: 95 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): glibc-headers-2.6. 100% |=========================| 598 kB    00:04     
(2/5): glibc-2.6.90-18.i6 100% |=========================| 5.4 MB    00:42     
(3/5): glibc-devel-2.6.90 100% |=========================| 2.4 MB    00:18     
(4/5): glibc-2.6.90-18.x8 100% |=========================| 4.8 MB    00:38     
(5/5): glibc-common-2.6.9 100% |=========================|  21 MB    02:42     
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package glibc-devel needs glibc = 2.6-4, this is not available.
Package glibc-devel needs glibc = 2.6-4, this is not available.
Package glibc-devel needs glibc-headers = 2.6-4, this is not available.
Package glibc-devel needs glibc-headers = 2.6-4, this is not available.
Complete!
Comment 1 James Antill 2007-10-11 15:33:07 EDT
 It looks like you have a plugin installed which is removing some of the updates
(after the update has been confirmed even -- which is bad). Or did you paste badly?
 Your problem seems to be that glibc-devel-2.6-4.i386 is installed and isn't
being upgraded. Try: rpm -q glibc-devel

 Is this BZ a feature request that the error messages "Package X needs ..."
should include the arch of the packages? -- Note that the provides cannot
include the arch.
Comment 2 James Antill 2007-10-11 15:36:40 EDT
 Hmm, maybe you already have the other 10 packages downloaded? If so ignore the
first sentence in my previous comment.
Comment 3 Luya Tshimbalanga 2007-10-11 16:27:50 EDT
The oher packages are downloaded. Here is the result of rpm -q glibc-devel:
glibc-devel-2.6-4
glibc-devel-2.6-4


Since I am running a x86_64 system, having almost identical package can be
confusing with no specification of architectures or difference.
Comment 4 Jeremy Katz 2007-10-11 16:34:04 EDT
Unfortunately, we can't tell anymore because we're not given anymore information
in the callback from rpm
Comment 5 Luya Tshimbalanga 2007-10-11 16:46:02 EDT
It looks like the issue is related to rpm itself. Perhaps that problem should be
addressed to rpm maintainer.
Comment 6 Jeff Johnson 2007-10-11 20:21:41 EDT
Try this:

    echo '%_query_all_fmt         %%{name}-%%{version}-%%{release}.%%{arch}' >> /etc/rpm/macros
    rpm -qa

Re comment #4: sure not on a callback. arch is displayed in problem sets however. too bad you have 
nevere figgered how to use.
Comment 7 Panu Matilainen 2007-10-24 04:44:42 EDT
See bug 349091, there are several different issues at play...
Comment 8 Panu Matilainen 2007-10-25 08:09:46 EDT
Created attachment 237301 [details]
Use rpm's own messages for rpm_check_debug output

What can be fixed in rpm 4.4.x (without breaking compatibility) has been fixed
as of rpm >= 4.4.2.2-7.fc9 (see bug 349091 for long version). The callback
tuple can't be changed atm but you can "fix" this by using rpm's own messages
for _run_rpm_check_debug() to get the arch in the output. Something like the
attached patch - untested but I suppose you'll get the idea...
Comment 9 Panu Matilainen 2007-10-25 08:10:37 EDT
...and back to yum...
Comment 10 Seth Vidal 2008-03-12 10:56:30 EDT
YUMBUGDAY
Comment 11 James Bowes 2008-03-17 07:48:03 EDT
Would this work correctly with i18n/l10n?
Comment 12 James Bowes 2008-03-17 08:56:40 EDT
Updated version of Panu's patch applied upstream.

Note You need to log in before you can comment on or make changes to this bug.