Bug 32831 - missed /sbin/loader
missed /sbin/loader
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 12:03 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-26 15:28:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-23 12:03:55 EST
During the installation when I do Alt-Ctl-F2 I go to shell.
There in /sbin there some common programs.
Among them there modprobe, insmod , etc
which are symlinked to ./loader
by the ./loader itself is missed,
So I can not do modprobe during the installation.

The fix is to add this program ./loader
Comment 1 Michael Fulbright 2001-03-26 16:13:32 EST
Brent please check into this, as well as with the latest internal tree.
Comment 2 Brent Fox 2001-03-27 14:24:40 EST
This works for me under 7.0.  Also works in the latest internal trees.
Comment 3 Need Real Name 2001-03-29 17:09:52 EST
I used RedHat 7.0 kickstart installation.
There is no loader in /sbin/
when I did Alt-F2
Comment 4 Need Real Name 2001-04-02 11:10:02 EDT
The loader exists in /sbin if I use standard boot disk and start
standard installation procedure.

In case I use kickstart installation
(or probably any other which uses bootnet.img)
THERE IS NO /sbin/loader.

I did not try bootpcmcia.img may be this problem exists with this disk also.
Comment 5 Brent Fox 2001-04-02 12:47:14 EDT
Oh, I wasn't aware you were using boot disks.  I was using the cd.  I was able
to reproduce the problem with a bootnet boot disk for 7.0.  However, it doesn't
happen with the bootnet boot disk in our internal testing builds, so apparently
this problem has been fixed.  However, the issue still exists if you use a
pcmcia boot disk.
Comment 6 Need Real Name 2001-04-02 13:05:37 EDT
 >However, it doesn't
 >happen with the bootnet boot disk in our internal testing builds, so
apparently
 >this problem has been fixed.  However, the issue still exists if you use a
 >pcmcia boot disk.

I hope you will fix this for 7.1 release,
because inability to do run modprobe
in case when installation process failed is very annoyning.
Comment 7 Matt Wilson 2001-04-02 15:24:49 EDT
what module do you need to insert?
Comment 8 Need Real Name 2001-04-02 15:38:39 EDT
>what module do you need to insert?

When using

device scsi ...
or 
device eth ...

in ks.cfg for the devices
the easiest thing to check whether the driver/parameters will work 
is just to do

modprobe  module_name options

If it works - I just put module name and options to ks.cfg and start
installation over.

The inability to do try manually wheter modprobe would work requires to make new
ks.cfg ,
try kickstart again , what is very time consuming.
Comment 9 Brent Fox 2001-04-02 18:25:54 EDT
It's too late to make this kind of change for the next release, but this is
something to think about for future releases.  Deferring for now.
Comment 10 Brent Fox 2001-09-26 15:29:31 EDT
This appears to have been fixed in our internal builds.

Note You need to log in before you can comment on or make changes to this bug.