Bug 328641 - rpmrebuild --help displays full path, instead of basename
rpmrebuild --help displays full path, instead of basename
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpmrebuild (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Anderson Silva
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 18:23 EDT by Chris Duryee
Modified: 2008-04-04 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 12:33:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Duryee 2007-10-11 18:23:31 EDT
Description of problem:
rpmrebuild --help shows full path name in help info, instead of just basename

Version-Release number of selected component (if applicable):


How reproducible: every time


Steps to Reproduce:
1. rpmrebuild --help
2.
3.
  
Actual results:

/usr/lib/rpmrebuild/rpmrebuild.sh is a tool to rebuild an rpm file from the rpm
database
Usage: /usr/lib/rpmrebuild/rpmrebuild.sh [options] package


Expected results:

 rpmrebuild --help

rpmrebuild is a tool to rebuild an rpm file from the rpm database
Usage: rpmrebuild [options] package



Additional info:
Comment 1 Steve Milner 2007-10-12 10:49:50 EDT
This is more than likely the result of using $0 ....

[smilner@arc ~]$ cat test.sh 
echo $0
[smilner@arc ~]$ sh test.sh 
test.sh
[smilner@arc ~]$ sh ./././test.sh 
./././test.sh
[smilner@arc ~]$ cat test2.sh 
echo `basename $0`
[smilner@arc ~]$ sh ./././test2.sh 
test2.sh
[smilner@arc ~]$ sh test2.sh 
test2.sh
[smilner@arc ~]$
Comment 2 Anderson Silva 2007-10-15 09:05:51 EDT
From Upstream:

Anderson Silva wrote:
> > by the way:
> > 
> > I am sure you know this, but here:
> > 
> > basename $0
> > 
> > should fix the issue.

not exactly, because 'rpmrebuild' is in the path, and not 'rpmrebuild.sh'

So I will not use $0 any more : the problem is fixed in svn, and will be
integrated in next release.


Note You need to log in before you can comment on or make changes to this bug.