Bug 3288 - KDE and damaged XPM icons
KDE and damaged XPM icons
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-05 15:09 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-23 12:51:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 1999-06-05 15:09:26 EDT
(Red Hat Linux 6.0 / KDE 1.1.1pre2)

Some component of KDE (kwm) seems to damage XPM icon data
which are retrieved from native Qt applications. Inside an
Qt app the icons look fine. But kpanel and kwm, for
instance, chop up the icons badly. Keeping ALT+TAB pressed
produces damaged icons that vary randomly (in other words,
hold down ALT, and then with each press of TAB an icon gets
damaged differently). The damage can be anything from light
to severe. Looks much like memory corruption or display of
freed memory:


http://www.geocities.com/SiliconValley/Lakes/5147/kwm-qt-xpm-mess-1.gif

http://www.geocities.com/SiliconValley/Lakes/5147/kwm-qt-xpm-mess-2.gif
  (2.5 KB)

Any Qt app I have tried causes kwm to print this error each
time an external icon is displayed:

  kwm: X_CopyArea(0x3800012): BadDrawable (invalid Pixmap or
Window parameter)

The XPM files themselves are fine, however, and work inside
the Qt app. With other window managers this is not an issue.
They work.
Comment 1 Red Hat Bugzilla 1999-06-21 12:10:59 EDT
I have a very strong feeling this is related to your video card.  We
have *never* seen this behaviour here nor had it reported by anyone
else, so it seems to be isolated to you.  Can you give us some more
info about your hardware?
Comment 2 Red Hat Bugzilla 1999-06-21 17:24:59 EDT
Wouldn't the card affect arbitrary icons then? This is beyond my
comprehension, I'm afraid.

Where's the difference between XPM icons displayed by Qt apps and
icons which are displayed by KDE apps?

How could my video card know whether an icon comes from Qt or KDE?

What has the video card to do with this kwm error message?

  kwm: X_CopyArea(0x3800012): BadDrawable (invalid Pixmap or
  Window parameter)

Frankly, it looks like a software bug rather than a hardware problem.
KDE 1.0 and Qt 1.41 didn't have this bug.

Again, _all_ icons look fine unless the application is a _native_ Qt
application and not Qt itself but kwm or kpanel display the apps'
pixmaps. The same icons displayed by kfm look fine.

The video card in question is an ELSA WINNER 1000 TRIO/V which
contains the S3 Trio64+ chipset and 2 MB, running at 1024x768 16-bit
hi-colour.

The machine is an Intel Pentium 133 MHz with ASUS P55TP4N mainboard,
64 KB of RAM, three Seagate (E)IDE HDs, SB AWE32 2MB, NE2000 network
adapter, parallel port ZIP drive, CD-ROM, ... but I doubt any of that
h/w has an influence on pixmaps.

Tell me if you need further info or any logs in particular (dmesg,
xinit, or so).
Comment 3 Red Hat Bugzilla 1999-06-22 10:47:59 EDT
I've installed RHL 6.0 from scratch on a completely different
machine (an old Intel 486DX 33 MHz) with a Diamond Speedstar 24
(ET4000 chipset) graphics card. Same software, same bug. How
else could it be?
Comment 4 Red Hat Bugzilla 1999-06-22 10:50:59 EDT
You seem correct, I didn't fully understand the problem until you
described it in more detail.

We'll look into this.
Comment 5 Red Hat Bugzilla 1999-09-23 12:51:59 EDT
fixed for the next release.
Comment 6 Red Hat Bugzilla 2000-04-01 16:03:59 EST
The bug is still present in Red Hat Linux 6.2, I'm afraid.
Comment 7 Red Hat Bugzilla 2000-04-01 16:10:59 EST
Created attachment 184
Comment 8 Red Hat Bugzilla 2000-09-08 15:26:19 EDT
As of Qt 2.2.0 this bug is gone.  

"qt1x-1.45-3" and "qt-2.1.0-4.beta1" from Red Hat Linux 6.2 i386 are bad.

So, apparently, it is a bug in Qt < 2.2.0 (haven't tried all releases between Qt
2.1.0 and Qt 2.2.0). Wonder why the KDE 1.x libraries and applications are not
affected, although they depend on Qt 1.x ... just _native_ Qt applications are
affected when being run in KDE.

Note You need to log in before you can comment on or make changes to this bug.