Bug 329131 - No hardware support for integrated webcam on Dell Inspiron 1520
No hardware support for integrated webcam on Dell Inspiron 1520
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://forum.notebookreview.com/showt...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 03:48 EDT by Răzvan Sandu
Modified: 2008-01-14 07:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 07:41:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-10-12 03:48:21 EDT
Hello,

Description of problem:

There is no hardware support for the integrated webcam on Dell Inspiron 1520
notebook.

No userland application seems to "see" the webcam.

Here is the smolt hardware profile of Dell Inspiron 1520:

http://smolt.fedoraproject.org/show?UUID=28caf2c3-9766-4fe1-9e4c-d6b0ba8a0132

and here is the full output of /sbin/lspci -vv

http://forum.notebookreview.com/showthread.php?t=152717

Version-Release number of selected component (if applicable):
kernel-2.6.23-5.fc8

How reproducible:
Always.

  
Actual results:
Integrated webcam is not recognised by any application on Dell Inspiron 1520.

Expected results:
Integrated webcam should be "seen" by applications, at least in VGA mode.


Regards,
Răzvan
Comment 1 Chuck Ebbert 2007-10-12 19:33:03 EDT
uvc_driver.c needs:

/* OmniVision OEM Dell Notebook */
	{ .match_flags		= USB_DEVICE_ID_MATCH_DEVICE
				| USB_DEVICE_ID_MATCH_INT_INFO,
	  .idVendor		= 0x05a9,
	  .idProduct		= 0x2640,
	  .bInterfaceClass	= USB_CLASS_VIDEO,
	  .bInterfaceSubClass	= 1,
	  .bInterfaceProtocol	= 0,
	  .driver_info		= UVC_QUIRK_PROBE_MINMAX },
Comment 2 Răzvan Sandu 2007-10-17 14:02:25 EDT
Hello,

That means the webcam will be functional at FC8 final release ?
I'm not a programmer... ;-)

Regards,
Răzvan
Comment 3 Răzvan Sandu 2007-10-29 12:09:52 EDT
Hope to help:

According to Dell's site and official Windows drivers, the webcam for this Dell
Inspiron 1520 seems to be manufactured by Creative Labs.

Dell offers a Windows application for using the camera (live chat, etc.). This
application is made by Creative Labs too.

*If* the camera arrives to work, are there any particular recommendations for a
specific easy-to-use application for actually using/testing such a webcam in
Fedora (taking pictures, video chat, etc.) ?

Thank you,
Răzvan
Comment 4 Chuck Ebbert 2007-10-29 13:49:58 EDT
Apparently the UVC driver isn't in the upstream Linux kernel yet, so we don't
have it in Fedora.

But this looks like a good resource:

http://www.linuxtv.org/v4lwiki/index.php/Webcams
Comment 5 Hans de Goede 2008-01-14 07:41:11 EST
Work is underway (lead by suse) to integrate the support for uvc camera's in the
mainline kernel, in the mean you can download the out of tree driver here:

http://linux-uvc.berlios.de/

Closing this with a resolution of upstream.

Note You need to log in before you can comment on or make changes to this bug.