Bug 33017 - Dell Latitude LS500; nm256_audio = total freeze
Summary: Dell Latitude LS500; nm256_audio = total freeze
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-24 01:05 UTC by David Sainty
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 03:36:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v from Dell Latitude LS500 (3.09 KB, text/plain)
2001-03-24 01:11 UTC, David Sainty
no flags Details
magic frobbage that supposedly fixes the driver on some laptops (3.87 KB, patch)
2002-01-24 03:35 UTC, Bill Nottingham
no flags Details | Diff

Description David Sainty 2001-03-24 01:05:13 UTC
Dell Latitude LS500, rawhide-20010321, kernel-2.4.2-0.1.35,
sndconfig-0.64.7-1....

Doing a "modprobe nm256_audio" freezes the system.  Things investigated:

- Turn off all devices that can be turned off in BIOS.
- Set PnP OS to no (instead of yes).
- Load module in run level 1, without X (in case XFree86 was preventing
audio from getting memory - since its a multi-function chip).
- Try from cold boot to prevent warm reboot issues.
- Latest rawhide kernel used; sound has never worked on machine (in Linux,
unknown in Windoze since never used)

nm256_audio obviously works on some systems, e.g. on a Inspiron 3500.

lspci gives:

01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV]
(rev 20)
01:00.1 Multimedia audio controller: Neomagic Corporation [MagicMedia 256AV
Audio] (rev 20)

lspci is attached.

Other NM256 related reports:   #27509, #31710, #30672

Thoughts appreciated.

Comment 1 David Sainty 2001-03-24 01:11:39 UTC
Created attachment 13543 [details]
lspci -v from Dell Latitude LS500

Comment 2 David Sainty 2001-04-08 15:21:58 UTC
Latest rawhide-20010407 (Apr 7th), kernel-2.4.2-0.1.51...

sndconfig detects card, machine still freezes when sndconfig tries to play sound.

Comment 3 Bill Nottingham 2001-04-09 03:53:29 UTC
No, nm256_audio does *not* work on a 3500, FWIW. :)

Do you get any warnings from the module, or does it just kill the system?

Are there any settings for the sound card in the BIOS?

Comment 4 Bill Nottingham 2002-01-24 03:34:40 UTC
Does the attached work for you?

Comment 5 Bill Nottingham 2002-01-24 03:35:45 UTC
Created attachment 43354 [details]
magic frobbage that supposedly fixes the driver on some laptops


Note You need to log in before you can comment on or make changes to this bug.