Bug 330891 - Guest domain config not getting saved
Summary: Guest domain config not getting saved
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-13 19:43 UTC by Naresh Sukhija
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-13 20:29:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Naresh Sukhija 2007-10-13 19:43:52 UTC
Description of problem:
Whenever I create a guest using, its configuration file doesn't get saved under
/etc/xen

Version-Release number of selected component (if applicable):
FC8 Test3 i686

How reproducible:
Try to install a xen paravirt guest through either virt-install or virt-manager

Steps to Reproduce:
1. Run virt-install or virt-manager
2. Install the guest OS, after successful installation, the guest reboots
3. Still the guest configuration file for example /etc/xen/vm1 (for the guest
named vm1) doesn't get created
  
Actual results:
The guest configuration file for example /etc/xen/vm1 (for the guest named vm1)
doesn't get created

Expected results:
The guest configuration file should get created under /etc/xen for example
/etc/xen/vm1

Additional info:

Comment 1 Daniel Berrange 2007-10-13 20:29:54 UTC
The /etc/xen directory has not been used since Xen 3.0.3 in FC6. All current
releases of Xen keep guest configs internal to XenD in non-admin facing
datastore in /var/lib. You can use 'virsh dumpxml {NAME|ID|UUID}' to query the
config for a guest.


Note You need to log in before you can comment on or make changes to this bug.