This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 33107 - rp3 crashes with seg fault
rp3 crashes with seg fault
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-24 21:45 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:41:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-24 21:45:31 EST
Fequently, but not always, when I bring up rp3 it will crash shortly after
I press "yes" to the question about starting the interface. The interface
is started inspite of the crash because when I bring up Netscape my modem
is dialed to my ISP when I attempt to access a URL.

I ran 
   gdb /usr/bin/rp3 789
where 789 was the process id as reported by GNOME immediately after the
most recent crash. After gdb came up I entered "bt" with the results shown
below. GNOME reported that the cause of the crash was a seg fault.

-------------bt output-----------------------------------
(gdb) bt
#0  0x40565869 in __wait4 () from /lib/libc.so.6
#1  0x405d11c8 in __DTOR_END__ () from /lib/libc.so.6
#2  0x40090b38 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#3  <signal handler called>
#4  0x40239118 in gtk_type_check_object_cast () from
/usr/lib/libgtk-1.2.so.0
#5  0x804e641 in display_unwait ()
#6  0x4040c983 in g_timeout_dispatch () from /usr/lib/libglib-1.2.so.0
#7  0x4040b987 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#8  0x4040c001 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#9  0x4040c1cc in g_main_run () from /usr/lib/libglib-1.2.so.0
#10 0x401dbe57 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#11 0x4006a44d in gnome_dialog_run_real () from /usr/lib/libgnomeui.so.32
#12 0x4006a561 in gnome_dialog_run_and_close () from
/usr/lib/libgnomeui.so.32
#13 0x804e5df in display_unwait ()
#14 0x40290958 in gdk_io_invoke () from /usr/lib/libgdk-1.2.so.0
#15 0x4040a1a0 in g_io_unix_dispatch () from /usr/lib/libglib-1.2.so.0
#16 0x4040b987 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#17 0x4040c001 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#18 0x4040c1cc in g_main_run () from /usr/lib/libglib-1.2.so.0
#19 0x401dbe57 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#20 0x4006a44d in gnome_dialog_run_real () from /usr/lib/libgnomeui.so.32
#21 0x4006a561 in gnome_dialog_run_and_close () from
/usr/lib/libgnomeui.so.32
#22 0x804ed9c in display_unwait ()
---Type <return> to continue, or q <return> to quit--- 
#23 0x804ee89 in display_set_status ()
#24 0x401dd8b3 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#25 0x4020fc0a in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
#26 0x4020ef4d in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#27 0x4020ccf5 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#28 0x401dd8b3 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#29 0x4020fc0a in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
#30 0x4020ef4d in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#31 0x4020ccf5 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#32 0x401759fd in gtk_button_clicked () from /usr/lib/libgtk-1.2.so.0
#33 0x4017725d in gtk_real_button_released () from /usr/lib/libgtk-1.2.so.0
#34 0x401dd8b3 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#35 0x4020edd8 in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#36 0x4020ccf5 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#37 0x4017592d in gtk_button_released () from /usr/lib/libgtk-1.2.so.0
#38 0x40176b47 in gtk_button_button_release () from
/usr/lib/libgtk-1.2.so.0
#39 0x401dd57e in gtk_marshal_BOOL__POINTER () from
/usr/lib/libgtk-1.2.so.0
#40 0x4020ef8c in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#41 0x4020ccf5 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#42 0x40246c39 in gtk_widget_event () from /usr/lib/libgtk-1.2.so.0
#43 0x401dd4f5 in gtk_propagate_event () from /usr/lib/libgtk-1.2.so.0
#44 0x401dc5bf in gtk_main_do_event () from /usr/lib/libgtk-1.2.so.0
#45 0x40291c21 in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
---Type <return> to continue, or q <return> to quit---
#46 0x4040b987 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#47 0x4040c001 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#48 0x4040c1cc in g_main_run () from /usr/lib/libglib-1.2.so.0
#49 0x401dbe57 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#50 0x40429e37 in applet_widget_gtk_main () from
/usr/lib/libpanel_applet.so.0
#51 0x804db62 in _start ()
#52 0x404d0b5c in __libc_start_main (main=0x804df00 <main>, argc=5, 
    ubp_av=0xbffffae4, init=0x804c7bc <_init>, fini=0x805746c <_fini>, 
    rtld_fini=0x4000d634 <_dl_fini>, stack_end=0xbffffadc)
    at ../sysdeps/generic/libc-start.c:129
(gdb) 
---------------end of bt output -------------------------------------

This has been a presistent problem since installing Red Hat 7.0 a month or
so ago.  I am using rp3 1.1.4 whch came with Red Hat.

Jim
Comment 1 Changed to DavidTangye@hotmail.com 2001-03-31 00:38:15 EST
It is possible that this is a duplicate of the bug 18749, also reported as
20324, 24535, 25311 and possibly others. Perhaps your rp3 dialup simply fails,
but due to your setting about Autodialing being set (refer bug 17910) you get a
dialup as soon as Netscape is started? Just a guess. I might be wrong.
Comment 2 Changed to DavidTangye@hotmail.com 2001-03-31 01:23:30 EST
This might help (... from Bug#: 20324)
------- Additional comments from ljarno@free.fr 2000-11-16 16:15:53 -------

 G'day,
 I  had exactly the same problem ("Failed to activate interface") when using
 "rp3".
 Here is what I did to fix this trouble :
 1) Open the "Dial up Configuration" menu ;
 2) Select the "Advanced" tab ;
 3) Uncheck "Bring link up and down automatically" option.
 Hope it could help.
 Ludovic (ljarno@free.fr)

This fixed the problem for me too
Comment 3 Bill Nottingham 2006-08-07 15:18:51 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 4 Bill Nottingham 2006-10-18 12:41:05 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.