Bug 331231 - Integrated 8-in-1 card-reader on Dell Inspiron 1520 (Ricoh) only supports SD cards
Integrated 8-in-1 card-reader on Dell Inspiron 1520 (Ricoh) only supports SD ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
http://forum.notebookreview.com/showt...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 04:01 EDT by Răzvan Sandu
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 12:13:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2007-10-14 04:01:19 EDT
Hello,

Description of problem:

It seems the integrated multi-format card-reader on Dell Inspiron 1520 notebook
is not supported/recognised.

Reader seems to be manufactured by Ricoh. The 8-in-1 memory card reader reads
the following memory cards:

    * Secure Digital (SD)

    * SDIO

    * MultiMediaCard (MMC)

    * Memory Stick

    * Memory Stick PRO

    * xD-Picture Card

    * Hi Speed-SD

    * Hi Density-SD

(http://support.dell.com/support/edocs/systems/ins1520/en/om_en/html/cardread.htm#wp1063919)

Inserting a test xD card in the reader doesn't mount it - no icon shows up on
the desktop.

Here is the smolt hardware profile of Dell Inspiron 1520:

http://smolt.fedoraproject.org/show?UUID=28caf2c3-9766-4fe1-9e4c-d6b0ba8a0132

and here is the full output of /sbin/lspci -vv

http://forum.notebookreview.com/showthread.php?t=152717

Version-Release number of selected component (if applicable):
kernel-2.6.23-5.fc8

How reproducible:
Always.

  
Actual results:
Integrated card-reader on Dell Inspiron 1520 is not recognised.

Expected results:
Integrated card-reader should have hardware support.
Inserting a card when running in X mode should mount it automatically and a new
icon should appear on the desktop.
A canonical way to manually mount/unmount the cards when in text mode should be
provided, including a way to find out card-reader's device name.


Regards,
Răzvan
Comment 1 Chuck Ebbert 2007-10-15 12:13:44 EDT
Only SD cards work, there is no kernel support for any other type. Upstream
developers know about this already.

Note You need to log in before you can comment on or make changes to this bug.