Bug 331371 - This error ocurred on update. FEDORA 8 test3
This error ocurred on update. FEDORA 8 test3
Status: CLOSED DUPLICATE of bug 321251
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-14 10:58 EDT by Alex Sts
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-16 14:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Exception Ocurred (3.42 KB, text/plain)
2007-10-14 10:58 EDT, Alex Sts
no flags Details

  None (edit)
Description Alex Sts 2007-10-14 10:58:25 EDT
Component: pirut
Summary: TB19ba829d __init__.py:158:pirutCDHandler:NameError: global name
'DBusException' is not defined

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 474, in <module>
  File "/usr/sbin/pirut", line 470, in main
  File "/usr/sbin/pirut", line 398, in run
  File "/usr/sbin/pirut", line 414, in doRefresh
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 302, in
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 268, in reposSetup
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 64, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 78, in _getTs
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 522, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 239, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 142, in populate
    if self._check_db_version(repo, mydbtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 199, in
    if repo.repoXML.repoData.has_key(mdtype):
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 758, in <lambda>
    repoXML = property(fget=lambda self: self._getRepoXML(),
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 750, in _getRepoXML
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 733, in _loadRepoXML
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 563, in _getFile
    result = self.mediafunc(local = local, checkfunc = checkfunc, relative =
relative, text = text, copy_local = copy_local, url = url, mediaid =
self.mediaid, name = self.name, discnum = discnum, range = (start, end))
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 158, in
    except DBusException, e:
NameError: global name 'DBusException' is not defined

Local variables in innermost frame:
hal: <Interface <ProxyObject wrapping <dbus._dbus.SystemBus (system) at
0x9c1d3bc> :1.4 /org/freedesktop/Hal/Manager at 0x9c2d8cc> implementing
'org.freedesktop.Hal.Manager' at 0x9c2d88c>
name: Fedora 7.92
self: <__main__.PackageManager object at 0x9b5f64c>
args: ()
umount: False
mediaid: 1191241688.811639
HalCD: <module 'pirut.HalCD' from
dev: <pirut.HalCD.HALBlockDevice instance at 0x9c2d60c>
discnum: 1
kwargs: {'mediaid': '1191241688.811639', 'name': 'Fedora 7.92', 'url': None,
'text': <yum.yumRepo.YumRepository object at 0x9c1a34c>, 'relative':
'repodata/repomd.xml', 'range': (None, None), 'checkfunc': (<bound method
YumRepository._checkRepoXML of <yum.yumRepo.YumRepository object at 0x9c1a34c>>,
(), {}), 'copy_local': 1, 'discnum': 1, 'local':
found: False
cdudi: /org/freedesktop/Hal/devices/storage_model_DVDRAM_GSA_H42N
Comment 1 Alex Sts 2007-10-14 10:58:25 EDT
Created attachment 226671 [details]
Exception Ocurred
Comment 2 Jeremy Katz 2007-10-16 14:03:50 EDT

*** This bug has been marked as a duplicate of 321251 ***

Note You need to log in before you can comment on or make changes to this bug.