Bug 331381 - Quit -> rhythmbox crashes
Quit -> rhythmbox crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 12:55 EDT by sangu
Modified: 2007-12-01 23:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-01 23:21:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhythmbox --gst-fatal-warnings, backtrace file. (28.48 KB, text/plain)
2007-10-16 12:43 EDT, sangu
no flags Details

  None (edit)
Description sangu 2007-10-14 12:55:00 EDT
Description of problem:
quit (ctrl - q) make rhytmbox crash.

Distribution: Fedora release 7.92 (Rawhide)
Gnome Release: 2.20.0 2007-09-27 (Red Hat, Inc)
BugBuddy Version: 2.20.0

System: Linux 2.6.23-6.fc8 #1 SMP Thu Oct 11 14:54:16 EDT 2007 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: No
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: Tango

Memory status: size: 134131712 vsize: 134131712 resident: 45436928 share:
23777280 rss: 45436928 rss_rlim: 4294967295
CPU usage: start_time: 1192379813 rtime: 2182 utime: 1986 stime: 196 cutime:0
cstime: 2 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/rhythmbox'

[?1034hUsing host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208285408 (LWP 10768)]
[New Thread -1249567856 (LWP 10773)]
0x0012d402 in __kernel_vsyscall ()
#0  0x0012d402 in __kernel_vsyscall ()
#1  0x0039b43b in waitpid () from /lib/libpthread.so.0
#2  0x00fb3967 in IA__g_spawn_sync (working_directory=0x0, argv=0x9869518, 
    envp=0x0, flags=G_SPAWN_SEARCH_PATH, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, error=0x92ffdb8)
    at gspawn.c:364
#3  0x00fb3c7c in IA__g_spawn_command_line_sync (
    command_line=0x987cfc8 "bug-buddy --appname=\"rhythmbox\" --pid=10768", 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, error=0x92ffdb8)
    at gspawn.c:672
#4  0x046bd360 in run_bug_buddy (appname=0x923fad0 "rhythmbox", 
    pid=<value optimized out>, minidump_path=<value optimized out>)
    at gnome-breakpad.cc:211
#5  0x046bd671 in check_if_gdb (callback_context=0x0) at gnome-breakpad.cc:281
#6  0x046bdb83 in google_breakpad::ExceptionHandler::InternalWriteMinidump (
    this=0x46c79e0, signo=11, sighandler_ebp=154145352, sig_ctx=0x9301234)
    at ../google-breakpad/src/client/linux/handler/exception_handler.cc:225
#7  0x046be08e in google_breakpad::ExceptionHandler::HandleException (signo=11)
    at ../google-breakpad/src/client/linux/handler/exception_handler.cc:196
#8  <signal handler called>
#9  gdk_event_dispatch (source=0x92ffbb8, callback=0, user_data=0x0)
    at gdkevents-x11.c:2356
#10 0x00f820fc in IA__g_main_context_dispatch (context=0x9300b80)
    at gmain.c:2061
#11 0x00f8553f in g_main_context_iterate (context=0x9300b80, block=1, 
    dispatch=1, self=0x922e410) at gmain.c:2694
#12 0x00f858e9 in IA__g_main_loop_run (loop=0x99c8830) at gmain.c:2898
#13 0x007bc9a4 in IA__gtk_main () at gtkmain.c:1144
#14 0x08060eee in main (argc=156650040, argv=0x0) at main.c:306

Thread 2 (Thread -1249567856 (LWP 10773)):
#0  0x0012d402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x003975c5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
No locals.
#2  0x00f64d42 in g_async_queue_pop_intern_unlocked (queue=0x935f338, 
    try=<value optimized out>, end_time=0x0) at gasyncqueue.c:334
	retval = <value optimized out>
	__PRETTY_FUNCTION__ = "g_async_queue_pop_intern_unlocked"
#3  0x00f650e5 in IA__g_async_queue_pop (queue=0x935f338) at gasyncqueue.c:374
	retval = <value optimized out>
	__PRETTY_FUNCTION__ = "IA__g_async_queue_pop"
#4  0x080abbd2 in action_thread_main (db=0x93520b8) at rhythmdb.c:2308
	action = (RhythmDBAction *) 0x93fb348
	result = <value optimized out>
	__FUNCTION__ = "action_thread_main"
	__PRETTY_FUNCTION__ = "action_thread_main"
#5  0x00fa569f in g_thread_create_proxy (data=0x9a01110) at gthread.c:635
	__PRETTY_FUNCTION__ = "g_thread_create_proxy"
#6  0x003934fb in start_thread () from /lib/libpthread.so.0
No locals.
#7  0x0138e20e in clone () from /lib/libc.so.6
	fstab_state = {fs_fp = 0x0, fs_buffer = 0x0, fs_mntres = {
    mnt_fsname = 0x0, mnt_dir = 0x0, mnt_type = 0x0, mnt_opts = 0x0, 
    mnt_freq = 0, mnt_passno = 0}, fs_ret = {fs_spec = 0x0, fs_file = 0x0, 
    fs_vfstype = 0x0, fs_mntops = 0x0, fs_type = 0x0, fs_freq = 0, 
    fs_passno = 0}}
	__elf_set___libc_subfreeres_element_fstab_free__ = (
    const void *) 0x13cdc40

Thread 1 (Thread -1208285408 (LWP 10768)):
#0  0x0012d402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x0039b43b in waitpid () from /lib/libpthread.so.0
No locals.
#2  0x00fb3967 in IA__g_spawn_sync (working_directory=0x0, argv=0x9869518, 
    envp=0x0, flags=G_SPAWN_SEARCH_PATH, child_setup=0, user_data=0x0, 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, error=0x92ffdb8)
    at gspawn.c:364
	outpipe = -1
	errpipe = -1
	pid = 10878
	fds = {__fds_bits = {16896536, 161132432, 4, 154139848, 16382609, 8, 
    161132432, 4, 16896536, 161132432, 4, 154139960, 16370259, 161132432, 
    16291936, 0, 0, 153281744, 64, 154140056, 16896536, 21031680, 56, 10, 
    154139940, 154139944, 159814936, 3, 0, 3145060, 161132432, 159895539}}
	ret = <value optimized out>
	outstr = (GString *) 0x0
	errstr = (GString *) 0x0
	failed = 0
	status = <value optimized out>
	__PRETTY_FUNCTION__ = "IA__g_spawn_sync"
#3  0x00fb3c7c in IA__g_spawn_command_line_sync (
    command_line=0x987cfc8 "bug-buddy --appname=\"rhythmbox\" --pid=10768", 
    standard_output=0x0, standard_error=0x0, exit_status=0x0, error=0x92ffdb8)
    at gspawn.c:672
	retval = 0
	argv = (gchar **) 0x9869518
	__PRETTY_FUNCTION__ = "IA__g_spawn_command_line_sync"
#4  0x046bd360 in run_bug_buddy (appname=0x923fad0 "rhythmbox", 
    pid=<value optimized out>, minidump_path=<value optimized out>)
    at gnome-breakpad.cc:211
	exec_str = (
    gchar *) 0x987cfc8 "bug-buddy --appname=\"rhythmbox\" --pid=10768"
	res = <value optimized out>
	error = (GError *) 0x0
#5  0x046bd671 in check_if_gdb (callback_context=0x0) at gnome-breakpad.cc:281
	mypath = "/usr/bin/rhythmbox", '\0' <repeats 236 times>
	gdb = (gchar *) 0x98777b0 "/usr/bin/gdb"
	appname = (gchar *) 0x923fad0 "rhythmbox"
	pid = 10768
#6  0x046bdb83 in google_breakpad::ExceptionHandler::InternalWriteMinidump (
    this=0x46c79e0, signo=11, sighandler_ebp=154145352, sig_ctx=0x9301234)
    at ../google-breakpad/src/client/linux/handler/exception_handler.cc:225
	guid = {data1 = 74217952, data2 = 64440, data3 = 2351, data4 = {
    72 'H', 18 '\022', 48 '0', 9 '\t', 112 'p', 56 '8', 18 '\022', 0 '\0'}}
	success = <value optimized out>
	guid_str =
"\000\001\000\000\000\005\000\000\000\000\000\000\000¥¥k\004\000\220k\004ðè\000\000\005\000\000\000 \237k\004Ðvl\004"
#7  0x046be08e in google_breakpad::ExceptionHandler::HandleException (signo=11)
    at ../google-breakpad/src/client/linux/handler/exception_handler.cc:196
	current_ebp = 154145352
	current_handler = (google_breakpad::ExceptionHandler *) 0x46c79e0
	sig_ctx = (sigcontext *) 0x0
#8  <signal handler called>
No symbol table info available.
#9  gdk_event_dispatch (source=0x92ffbb8, callback=0, user_data=0x0)
    at gdkevents-x11.c:2356
	display = <value optimized out>
	event = (GdkEvent *) 0xb5da5200
#10 0x00f820fc in IA__g_main_context_dispatch (context=0x9300b80)
    at gmain.c:2061
No locals.
#11 0x00f8553f in g_main_context_iterate (context=0x9300b80, block=1, 
    dispatch=1, self=0x922e410) at gmain.c:2694
	got_ownership = <value optimized out>
	max_priority = 2147483647
	timeout = 331
	some_ready = 1
	nfds = <value optimized out>
	allocated_nfds = <value optimized out>
	fds = (GPollFD *) 0xb5dbf1d0
	__PRETTY_FUNCTION__ = "g_main_context_iterate"
#12 0x00f858e9 in IA__g_main_loop_run (loop=0x99c8830) at gmain.c:2898
	got_ownership = 3756848
	self = (GThread *) 0x922e410
	__PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#13 0x007bc9a4 in IA__gtk_main () at gtkmain.c:1144
	tmp_list = (GList *) 0x930dcdc
	functions = (GList *) 0x0
	init = (GtkInitFunction *) 0x932c068
	loop = (GMainLoop *) 0x99c8830
#14 0x08060eee in main (argc=156650040, argv=0x0) at main.c:306
	program = (GnomeProgram *) 0x9241010
	session_bus = (DBusGConnection *) 0x930dcdc
	error = (GError *) 0x0
	rb_shell = (RBShell *) 0x932c068
	new_argv = (char **) 0x9230730
	context = <value optimized out>
	options = {{long_name = 0x80f0169 "debug", short_name = 100 'd', 
    flags = 0, arg = G_OPTION_ARG_NONE, arg_data = 0x810a8a8, 
    description = 0x80da014 "Enable debug output", arg_description = 0x0}, {
    long_name = 0x80da028 "debug-match", short_name = 68 'D', flags = 0, 
    arg = G_OPTION_ARG_STRING, arg_data = 0x810a8ac, 
    description = 0x80da1b4 "Enable debug output matching a specified string", 
    arg_description = 0x0}, {long_name = 0x80da034 "no-update", 
    short_name = 0 '\0', flags = 0, arg = G_OPTION_ARG_NONE, 
    arg_data = 0x810a8c4, 
    description = 0x80da1e4 "Do not update the library with file changes", 
    arg_description = 0x0}, {long_name = 0x80da03e "no-registration", 
    short_name = 110 'n', flags = 0, arg = G_OPTION_ARG_NONE, 
    arg_data = 0x810a8b0, description = 0x80da04e "Do not register the shell", 
    arg_description = 0x0}, {long_name = 0x80da068 "dry-run", 
    short_name = 0 '\0', flags = 0, arg = G_OPTION_ARG_NONE, 
    arg_data = 0x810a8c0, 
    description = 0x80da210 "Don't save any data permanently (implies
--no-registration)", arg_description = 0x0}, {long_name = 0x80da070
"rhythmdb-file", 
    short_name = 0 '\0', flags = 0, arg = G_OPTION_ARG_STRING, 
    arg_data = 0x810a8bc, 
    description = 0x80da07e "Path for database file to use", 
    arg_description = 0x0}, {long_name = 0x80da09c "playlists-file", 
    short_name = 0 '\0', flags = 0, arg = G_OPTION_ARG_STRING, 
    arg_data = 0x810a8b8, 
    description = 0x80da24c "Path for playlists file to use", 
    arg_description = 0x0}, {long_name = 0x80dbf4d "quit", 
    short_name = 113 'q', flags = 0, arg = G_OPTION_ARG_NONE, 
    arg_data = 0x810a8b4, description = 0x80da0ab "Quit Rhythmbox", 
    arg_description = 0x0}, {long_name = 0x80e08be "", short_name = 0 '\0', 
    flags = 0, arg = G_OPTION_ARG_STRING_ARRAY, arg_data = 0x810a8c8, 
    description = 0x0, arg_description = 0x80da0ba "[URI...]"}, {
    long_name = 0x0, short_name = 0 '\0', flags = 0, arg = G_OPTION_ARG_NONE, 
    arg_data = 0x0, description = 0x0, arg_description = 0x0}}
	__FUNCTION__ = "main"
#0  0x0012d402 in __kernel_vsyscall ()
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y;
input not from terminal]



Version-Release number of selected component (if applicable):
0.11.2-9.fc8

How reproducible:
always

Steps to Reproduce:
1. Launch rhymbox
2. Play music
3. Quit (ctrl - q)
  
Actual results:


Expected results:


Additional info:
Comment 1 Bastien Nocera 2007-10-16 12:10:00 EDT
I can't reproduce that problem. Any errors on the command-line when this happens?
Comment 2 sangu 2007-10-16 12:32:00 EDT
$ rhythmbox

(rhythmbox:4353): GStreamer-WARNING **: pad mpegaudioparse0:src returned caps
which are not a real subset of its template caps

(rhythmbox:4353): GStreamer-WARNING **: pad mpegaudioparse0:src returned caps
which are not a real subset of its template caps

warning: Missing the separate debug info file:
/usr/lib/debug/.build-id/e4/c3c2bf6e0ed4750bd3237b09f964ab08e0bad2.debug

warning: Missing the separate debug info file:
/usr/lib/debug/.build-id/42/fd6328a34a3436d7c60950b64bd79d998688f7.debug
[...]
warning: Missing the separate debug info file:
/usr/lib/debug/.build-id/c2/aead9101ffd98f361bdb878bcb85efd5f3e062.debug
Comment 3 sangu 2007-10-16 12:43:01 EDT
Created attachment 228991 [details]
rhythmbox --gst-fatal-warnings, backtrace file.

When launching with rhythmbox --gst-fatal-warnings, clicking play button make
rhythmbox crash.
Comment 4 sangu 2007-10-16 12:53:10 EDT
attachment 228991 [details] is  rhythmbox --g-fatal-warnigs bactrace file. Sorry.

Default OutPut - PulseAudio  Sound Server.
Comment 5 Bastien Nocera 2007-10-17 15:26:03 EDT
The warnings you see are innocuous.

Can you explain exactly how to reproduce the crash? Are you playing Ogg files,
or MP3 files? Are you using the cross-fade (see the prefs)? Did you use any of
the plugins? Are you using the visualisations?

FYI, it looks like http://bugzilla.gnome.org/show_bug.cgi?id=484988 but the
upstream bug contains just about as much data as this one for figuring it out...

Note You need to log in before you can comment on or make changes to this bug.