Bug 331451 - system-config-network tends to empty /etc/hosts
system-config-network tends to empty /etc/hosts
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 16:04 EDT by Gordon Messmer
Modified: 2008-01-11 17:20 EST (History)
0 users

See Also:
Fixed In Version: 1.4.7-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-11 17:20:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2007-10-14 16:04:08 EDT
Description of problem:
When system-config-network starts, it has no values in the hosts tab.  If any
changes in the network configuration are saved, /etc/hosts will be emptied.

Version-Release number of selected component (if applicable):
system-config-network-1.4.2-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Run system-config-network
2. "Save" without making any changes
  
Actual results:
/etc/hosts is empty

Expected results:
The contents of /etc/hosts should not be changed. (or should have equivalent
contents)
Comment 1 Fedora Update System 2007-12-06 15:44:56 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'
Comment 2 Gordon Messmer 2007-12-11 23:57:06 EST
The update works for me.  I can add and remove hostnames without getting an
empty /etc/hosts file.
Comment 3 Fedora Update System 2008-01-11 17:20:31 EST
system-config-network-1.4.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.