Bug 33146 - kudzu dumps core
Summary: kudzu dumps core
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-26 00:40 UTC by Chris Ricker
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-26 06:26:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of ltrace -S (393.82 KB, application/octet-stream)
2001-03-26 06:24 UTC, Chris Ricker
no flags Details
output of ltrace -S -L (20.52 KB, text/plain)
2001-03-26 06:25 UTC, Chris Ricker
no flags Details
output of strace -f (23.40 KB, text/plain)
2001-03-26 06:26 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2001-03-26 00:40:14 UTC
I just upgraded from 7.0 to qa0322 + a custom kernel (2.4.3-pre6).  Kudzu
segfaults on startup:

Checking for new hardware/etc/init.d/kudzu: line 78:  7508 Segmentation
fault      (core dumped) /usr/sbin/kudzu $KUDZU_ARGS -t 30
                                                           [FAILED]

core dump attached (in a minute)

Comment 1 Chris Ricker 2001-03-26 00:54:27 UTC
Actually, I won't attach the core file, since mozilla times out whenever I try.
 I'm not sure if the problem is mozilla or bugzilla (the core file is 950k, so
perhaps its hitting a resource limit?)

Comment 2 Bill Nottingham 2001-03-26 02:58:45 UTC
Exactly what version of kudzu do you have installed?

Comment 3 Chris Ricker 2001-03-26 03:18:53 UTC
kudzu-0.98.5-1


Comment 4 Bill Nottingham 2001-03-26 04:49:17 UTC
I'm assuming this is reproducible from the command line. ltrace -S output?
(if it's too big, mail it directly.)


Comment 5 Chris Ricker 2001-03-26 06:24:17 UTC
Created attachment 13623 [details]
output of ltrace -S

Comment 6 Chris Ricker 2001-03-26 06:25:42 UTC
Created attachment 13624 [details]
output of ltrace -S -L

Comment 7 Chris Ricker 2001-03-26 06:26:32 UTC
Created attachment 13625 [details]
output of strace -f

Comment 8 Bill Nottingham 2001-03-26 16:08:56 UTC
Will be fixed in 0.98.6-1; thanks!


Note You need to log in before you can comment on or make changes to this bug.