Bug 331541 - hawknl 1.68 installs no .pc (pkg-config) file
hawknl 1.68 installs no .pc (pkg-config) file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hawknl (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 18:25 EDT by Michael Ploujnikov
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-15 03:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Ploujnikov 2007-10-14 18:25:10 EDT
Description of problem:
I'm unable to get the operating-system specific header location for hawknl using
pkg-config since the hawknl package does not install a .pc file.

Version-Release number of selected component (if applicable):
I've only tried hawknl-devel - 1.68-1.fc7.i386 and hawknl-devel - 1.68-1.fc7.x86_64.

How reproducible:


Steps to Reproduce:
1. $ pkg-config --libs hawknl
2.
3.
  
Actual results:
Package hawknl was not found in the pkg-config search path.
Perhaps you should add the directory containing `hawknl.pc'
to the PKG_CONFIG_PATH environment variable
No package 'hawknl' found


Expected results:
Something like:
-I/usr/include/hawknl

Additional info:
Comment 1 Hans de Goede 2007-10-15 03:22:18 EDT
Well actually one would expect "pkg-config --cflags hawknl" to produce
"-I/usr/include/hawknl" not "pkg-config --libs hawknl".

Atleast one would expect that if hawknl includes pkg-config support which it
doesn't. I've checked the upstream sources and they don't include a .pc nor a
.pc.in file. So pkg-config not working is to be expected and is not a bug.

Note You need to log in before you can comment on or make changes to this bug.