Bug 331611 - rhythmbox doesn't eject cds or media devices
rhythmbox doesn't eject cds or media devices
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 21:37 EDT by Roderic Morris
Modified: 2008-01-01 21:50 EST (History)
0 users

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-01 21:50:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"rhythmbox -d" output after inserting cd, and trying to eject (49.62 KB, text/plain)
2007-10-15 20:06 EDT, Roderic Morris
no flags Details

  None (edit)
Description Roderic Morris 2007-10-14 21:37:03 EDT
Description of problem: right-clicking on a device in rhythmbox and clicking
"eject" doesn't eject media as it should, but just brings up a dialog with a red
circle with a white line inside, and a close button.


Version-Release number of selected component (if applicable): 0.11.2-9.fc8.i386


How reproducible: insert a cd or plug in a media device into the computer, then
right click it's icon in rhythmbox and click the "eject" button.


Steps to Reproduce:
1.
2.
3.
  
Actual results: semi-useless dialog comes up


Expected results: device is unmounted or ejected


Additional info:
Comment 1 Bastien Nocera 2007-10-15 04:36:56 EDT
Do you see any errors on the command-line? If not, could you attach the output
of "rhythmbox -d" when reproducing the problem.

Which "media" were you trying to eject?
Comment 2 Roderic Morris 2007-10-15 20:06:12 EDT
Created attachment 228031 [details]
"rhythmbox -d" output after inserting cd, and trying to eject
Comment 3 Roderic Morris 2007-10-15 20:07:00 EDT
On the command line, without the -d option, it only outputs "gnome-mount 0.7"
when I try to eject my cd. I'm attaching the output with -d after I insert the
cd and then try to eject it from rhythmbox.
The other media I've tried is an mp3 player (an ipod). Rhythmbox's eject doesn't
work for either, but the gnome desktop, umount, eject, etc, still work.
Comment 4 Bastien Nocera 2007-10-16 05:14:54 EDT
rb_removable_media_manager_cmd_eject_medium():

        rb_removable_media_manager_unmount_volume (mgr, volume);
        gnome_vfs_volume_eject (volume,
(GnomeVFSVolumeOpCallback)rb_removable_media_manager_eject_medium_cb, mgr);
        gnome_vfs_volume_unref (volume);

If the eject doesn't work, then gnome-vfs or gnome-mount are to blame
(especially if the error feedback is poor). I couldn't reproduce the problem myself.

Note You need to log in before you can comment on or make changes to this bug.