Bug 331761 - pcspkr loads but still no sound, toshiba satellite a200 ah6
pcspkr loads but still no sound, toshiba satellite a200 ah6
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-15 02:23 EDT by Penelope Fudd
Modified: 2008-06-16 22:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 22:39:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2007-10-15 02:23:53 EDT
Description of problem:
I want my system to beep; I modified /etc/sysconfig/modules/udev-stw.modules to
have pcspkr, and now it loads on boot, but it's still not making any noise.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. modprobe pcspkr
2. system/preferences/hardware/sound , select system beep, check enable system
beep, close
3. echo \\a  (in gnome terminal or at system console)
4. listen
Actual results:
No beep.

Expected results:

Additional info:

dmesg says:
input: PC Speaker as /class/input/input5

Fedora 7 yum-updated as of Oct 14.

It's possible the system beep is routed through the sound card, but alsactl
doesn't show anything remotely similar to pc speaker.

Sound works, volume for everything is unmuted and maxed (except for the
microphone... owwwwww!)

There's nothing in /etc/modprobe.conf that would disable it.

It's not in any file in /etc/modprobe.d

It does show up in /sys/class/input/input5.  Here's modalias:

Google hasn't helped.
Comment 1 Andre Robatino 2007-10-15 08:01:45 EDT
  I don't know if it's relevant, but pcspkr is supposed to load automatically on
boot, but doesn't anymore since 2.6.22 - see bug #249124.  Also see
https://bugzilla.redhat.com/show_bug.cgi?id=249124#c1 which might be relevant,
though I don't understand it to be honest.
Comment 2 Penelope Fudd 2007-10-16 00:39:03 EDT
I saw that, but I'm past it.  I've gotten the module to load.  It just doesn't
produce sound.

I'm half wondering if the system assumes that pcspkr is
/sys/class/input/inputXXX, where XXX is some mysterious number.
Comment 3 Christopher Brown 2008-01-14 14:09:23 EST

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.


I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 4 Penelope Fudd 2008-01-15 02:25:57 EST
It's still not beeping.  However, I'm not sure I'm testing it in the best way. 
Right now, the text consoles are all black, pressing enter has no effect.  I
suspect this is a side effect of hibernation, I'll try again after a reboot.

Because it's a new laptop, and HW manufacturers are always trying to reduce the
part count, I suspect that they've routed the system beep through the sound
card, but that's just a guess on my part.

Can you give me a straightforward test to see if the PC speaker hardware is
physically present?  My usual technique (echo \\a) isn't working.

Comment 5 Christopher Brown 2008-01-15 19:32:39 EST
I'm guessing you're using gnome-terminal. Have you checked under
Edit>Profiles>Edit that Terminal Bell is checked?
Comment 6 Penelope Fudd 2008-01-16 02:01:35 EST
It was, and is still checked.  Sorry; that was the first thing I looked for. :-)
Comment 7 Christopher Brown 2008-01-16 08:19:28 EST
Its wierd, I've searched everywhere for a known test to sound the pc speaker but
can't find one. There is a one line c program of:

int main(){puts("\a");}

which does pretty much the same as your echo \a above but neither work for me
unless terminal bell is checked. Which is why I asked. :)

I'm thinking you should really check the cable is connected if this is a desktop
machine. Other than that it really sounds like faulty hardware - there is not a
lot that can go wrong with these things though. Can you check the cables and
update this bug?
Comment 8 Penelope Fudd 2008-01-16 16:16:11 EST
My apologies; I wasn't clear.  This is a laptop, purchased new two months ago;
the console beep has never worked in Fedora, but I'd be reluctant to blame the
hardware.  I think I had it working in a different live linux cd distribution,
but I'm not certain, I'll have to retest it.
Comment 9 Penelope Fudd 2008-01-16 16:23:48 EST
I'm more curious to know if there's a sysctl or something for flexible control
of the speaker, something that lets you change the pitch and duration of the beep.
Comment 10 Christopher Brown 2008-01-16 17:42:00 EST
(In reply to comment #9)
> I'm more curious to know if there's a sysctl or something for flexible control
> of the speaker, something that lets you change the pitch and duration of the beep.

Yes, look at the xset commands:

man xset

for more info on this. Do you have a live cd you can use to boot from and test?

Comment 11 Christopher Brown 2008-02-15 21:48:29 EST
Any update on this?
Comment 12 Penelope Fudd 2008-02-16 19:14:57 EST
Hi; sorry for the delay.  

I just booted from a live CD (the Insert image from the Universal Boot CD,
kernel 2.4.26), and it worked, both from an xterm and from a text console.  The
xterm's beep had a different pitch from the text console's beep, don't know what
to think of that.

And what I meant was, was there a sysctl that would work from a text console;
xset is for X.
Comment 13 Christopher Brown 2008-02-17 12:04:43 EST
When I run:

# cat /dev/input/event6

and open a second xterm and generate some noises I get garbled output each time
the terminal bell rings. This also happens with terminal bell enabled in
gnome-terminal. I wonder if you have the same event created?

Could you also indicate what is under:


if anything?
Comment 14 Jeremy 2008-03-01 05:01:21 EST
(In reply to comment #13)
I am also trying to get my pc speaker to work but all attempts I've applied from
internet data mining are unsuccessful.

in response:
electrify:~ $ls /sys/devices/platform/pcspkr/
bus  driver  input:input5  modalias  power  subsystem  uevent
electrify:~ $

I am running Fedora 8....
Comment 15 Penelope Fudd 2008-03-01 13:59:58 EST
lrwxrwxrwx 1 root root    0 2008-03-01 10:56 bus -> ../../../bus/platform
lrwxrwxrwx 1 root root    0 2008-03-01 10:56 driver ->
lrwxrwxrwx 1 root root    0 2008-03-01 10:56 input:input4 ->
-r--r--r-- 1 root root 4096 2008-03-01 10:56 modalias
drwxr-xr-x 2 root root    0 2008-03-01 10:56 power
lrwxrwxrwx 1 root root    0 2008-03-01 10:56 subsystem -> ../../../bus/platform
-rw-r--r-- 1 root root 4096 2008-03-01 10:56 uevent
Comment 16 Bug Zapper 2008-05-14 10:44:53 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 17 Bug Zapper 2008-06-16 22:39:53 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.