Bug 33212 - assertion failure in file display.c
Summary: assertion failure in file display.c
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: screen   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Phil Copeland
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-26 10:57 UTC by David Balažic
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 22:25:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The spec file used to compile and make the rpm (6.37 KB, text/plain)
2001-03-26 11:00 UTC, David Balažic
no flags Details
/tmp/debug/screen.19783 (327 bytes, text/plain)
2001-03-26 11:16 UTC, David Balažic
no flags Details
/tmp/debug/SCREEN.19784 (22.26 KB, text/plain)
2001-03-26 11:21 UTC, David Balažic
no flags Details
/tmp/debug/screen.child (517 bytes, text/plain)
2001-03-26 11:27 UTC, David Balažic
no flags Details

Description David Balažic 2001-03-26 10:57:43 UTC
I compiled screen-3.9.8-3.srpm with the -DDEBUG option,
by changing the line in screen.spec :

<make CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
>make CFLAGS="$RPM_OPT_FLAGS -DDEBUG -D_GNU_SOURCE"

Then I added the line "debug on" in /home/root/.screenrc
and run screen. It showed the splash page and after I
pressed return it crashed. Last line in /tmp/debug/SCREEN.19784 was :

ASSERT(new >=0 && new <= 9) failed file display.c line 1836

I attach all three files from /tmp/debug and the used spec file.

The contents of ~root/.screenrc are :

bell_msg "bla"
debug on

Comment 1 David Balažic 2001-03-26 11:00:29 UTC
Created attachment 13643 [details]
The spec file used to compile and make the rpm

Comment 2 David Balažic 2001-03-26 11:16:02 UTC
Created attachment 13644 [details]
/tmp/debug/screen.19783

Comment 3 David Balažic 2001-03-26 11:21:57 UTC
Created attachment 13645 [details]
/tmp/debug/SCREEN.19784

Comment 4 David Balažic 2001-03-26 11:27:54 UTC
Created attachment 13663 [details]
/tmp/debug/screen.child

Comment 5 Crutcher Dunnavant 2001-06-26 20:21:24 UTC
this doesnt seem to happen in 3.9.9

Comment 6 David Balažic 2001-07-26 10:24:03 UTC
screen-3.9.9-1 recompiled with -DDEBUG

Crashes at the same point if /etc/screenrc contains a single line :
debug off

( actually you must use /usr/etc/screenrc , due to a packaging bug,
see bug #49535 )

Comment 7 David Balažic 2001-07-26 10:30:20 UTC
I forgot to mention that this time no assertion failure is reported, it just 
dies.

Comment 8 Phil Copeland 2002-08-12 18:06:40 UTC
Umm this is an unsupported change.
I don't see this behaviour in 3.9.11-8

Try rawhide (ftp://ftp.redhat.com/pub/redhat/linux/rawhide/SRPMS/SRPMS)

Phil
=--=


Note You need to log in before you can comment on or make changes to this bug.