Bug 332291 - autofs fails if nsswitch.conf doesn't have automount entry
autofs fails if nsswitch.conf doesn't have automount entry
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: Ian Kent
Brock Organ
: Regression
Depends On:
Blocks: 425883 429340
  Show dependency treegraph
 
Reported: 2007-10-15 09:35 EDT by Ian Kent
Modified: 2008-05-21 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:38:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to use "files" source if nsswitch dosn't specify an explicit map source (1.46 KB, patch)
2007-10-15 09:35 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2007-10-15 09:35:06 EDT
Description of problem:

If /etc/nsswitch.conf doesn't have an entry for automount
autofs fails to start.

Version-Release number of selected component (if applicable):
autofs-5.0.2-0.rc2.43.

How reproducible:
Always.

Steps to Reproduce:
Remove the line starting with "automount:" from
/etc/nsswitch.conf and try and start autofs.
  
Actual results:
autofs fails to start.

Expected results:
autofs should use files as the source of maps if there is
no entry in the nsswitch configuration.
Comment 1 Ian Kent 2007-10-15 09:35:06 EDT
Created attachment 227671 [details]
Patch to use "files" source if nsswitch dosn't specify an explicit map source
Comment 2 RHEL Product and Program Management 2007-10-15 09:45:43 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 9 errata-xmlrpc 2008-05-21 10:38:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.