Bug 33231 - Installer fails to find suitable drives (on MegaRaid) to partition
Installer fails to find suitable drives (on MegaRaid) to partition
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-26 10:07 EST by Larry Williamson
Modified: 2007-03-26 23:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 11:15:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci ; lspci -n output (1.58 KB, text/plain)
2001-03-26 14:04 EST, Larry Williamson
no flags Details
lsmod output (404 bytes, text/plain)
2001-03-26 14:25 EST, Larry Williamson
no flags Details
/proc/scsi/scsi output (23 bytes, text/plain)
2001-03-26 14:26 EST, Larry Williamson
no flags Details
lspci -vv output from two machines (21.44 KB, text/plain)
2001-03-27 10:07 EST, Larry Williamson
no flags Details

  None (edit)
Description Larry Williamson 2001-03-26 10:07:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


When kickstarting (nfs), the process appears to proceed without any 
problems until it is time to partition the drives. On this system I have 4 
36gig scsi drives connected via adaptec 7890 Ultra 160/m controllers and 
all the drives are under the control of a Dell MegaRaid Controller. At 
parition time, the message "no suitable drives were found" (or something 
very similiar, the word "suitable" is certainly there) is displayed and 
the installation stops.

I have tried to poke about on the other virtual consoles, but I don't see 
any helpful information.

This same machine can be kickstarted to RH7.0. I have also a "special" 
RH7.0 kickstart image that contains the 2.4.2 kernel from rawhide - this 
kickstarts okay too.

Reproducible: Always
Steps to Reproduce:
1.Pretty much a vanilla kickstart. I include a "zerombr yes" and 
a "clearpart --all" in the ks.cfg file
2.
3.
	

This same behaviour is found on two (very similiar) machines.

They are two and four processor Dell 6400's with the Dell PERC controller. 
Boot message from a 7.0 kernel tell me these are AMI MegaRAID 1.01 254 
commands). /proc/scsi/scsi tells me it is a MegaRAID Model: LD0 RAID5 
0403R Rev: 1.01) These machines have from 1 to 2 gig ram, 4x36gig drives 
(stiped into one big 100gig file system), two Adaptec 7899 Ultra 160/m 
controllers in each machine.
Comment 1 Matt Wilson 2001-03-26 12:20:29 EST
When you get to the message window that says it can't find drives to install on,
switch to Alt+F2 and run "cat /proc/scsi/scsi" and "lsmod" to make sure that
megaraid was loaded.
Comment 2 Larry Williamson 2001-03-26 12:36:47 EST
I am sorry I overlooked adding that detail. Indeed, the driver is NOT loaded.
Comment 3 Matt Wilson 2001-03-26 12:42:55 EST
on the same console (Alt+F2), please send me the output of "lspci; lspci -n"
Comment 4 Larry Williamson 2001-03-26 14:04:10 EST
Created attachment 13705 [details]
lspci ; lspci -n output
Comment 5 Larry Williamson 2001-03-26 14:06:30 EST
That lspci output attachment was just created on one of the the systems that 
has this trouble but is currently running rh7.0, kernel 2.2.16-22smp

I will boot it with kickstart and verify the details are the same.
Comment 6 Larry Williamson 2001-03-26 14:25:20 EST
Created attachment 13708 [details]
lsmod output
Comment 7 Larry Williamson 2001-03-26 14:26:02 EST
Created attachment 13709 [details]
/proc/scsi/scsi output
Comment 8 Larry Williamson 2001-03-26 14:27:23 EST
I verified the output of lspci and lspci -n are the same when the system is in
anaconda during kickstart as when running rh7.0
Comment 9 Matt Wilson 2001-03-26 14:37:45 EST
can you add "lspci -vv" output to this report as well?
Comment 10 Matt Wilson 2001-03-26 14:38:37 EST
Bill - can you verify that the correct module would load in this system?
Comment 11 Bill Nottingham 2001-03-26 14:42:47 EST
Yes, it's in the pcitable. Try switching the megaraid out of i2o mode.
Comment 12 Larry Williamson 2001-03-27 10:07:14 EST
Created attachment 13827 [details]
lspci -vv output from two machines
Comment 13 Matt Wilson 2001-03-28 00:58:57 EST
it seems you have your megaraid in I2O mode.  Go into the BIOS and turn that
off.
Comment 14 Larry Williamson 2001-03-28 11:15:10 EST
I2O did not have any effect. The other option was "Mass Storage". After changing
this parameter, the install still failed.

BUT!!

While preparing new lspci dumps for you I thought to cat /proc/version. This
showed me I was running a 2.2.16-22BOOT kernel dated from Aug22/2000. This
suggested to me that my problem might be with the kickstart floppy itself. I
have been using this same floppy for quite a while. Why this same floppy would
work okay for RH7.0 and Rawhide, I cannot imagine. But it does.

So, I created a new boot floppy from the wolverine bootnet.img file.

This worked!

So to summarize, it looks like there is some dependancy between the bootnet.img
used to kickstart the system and the version of Redhat that is to be installed,
at least this seems so with wolverine.

Comment 15 Michael Fulbright 2001-03-29 12:07:05 EST
Your boot image should always match the tree you are installing from.

Sorry for the confusion.

Note You need to log in before you can comment on or make changes to this bug.