Bug 332641 - LTC39659: 201190: Include librtas package
LTC39659: 201190: Include librtas package
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: librtas (Show other bugs)
4.7
ppc64 All
low Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 10:35 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-17 16:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 39659 None None None Never

  None (edit)
Description IBM Bug Proxy 2007-10-15 10:35:24 EDT
=Comment: #0=================================================
Stephanie A. Glass <sglass&#64;us.ibm.com> - 2007-10-15 10:28 EDT
1. Feature Id 	201190
Feature Name 	Include librtas package
Sponsor 	PPC
Category 	Power Servicability
Request Type 	Package - New

2. Short Description 	Include the librtas package, which provides libraries for
accessing PowerPC firmware calls and for processing the output of those firmware
calls. The librtas package can be downloaded from http://librtas.ozlabs.org/.
Architecture 	ppc64 	
Architecture Specific ? Purely Arch Specific Code 	
Affects Toolchain ? no
Affects Installer ? no	
Affects Desktop ? no	
Affects Core Kernel (not mod)? 	no
Affects Kernel Module ? no
	
3. Describe the Business Case 	The librtas package enables a number of utilities
(including those in powerpc-utils-papr) to access PowerPC-specific firmware
calls. Without these libraries, these utilities will be unable to perform the
firmware calls that are necessary to enable hardware diagnostics, service
procedures, dynamic logical partitioning, etc.
Performance Assistance Required? 	no
Benefits 	The librtas package provides interfaces that are needed by diagnostic
and service tools, DLPAR tools, etc.
 	
4. Sponsor Priority 	
IBM Confidential 	no
Code Contribution ? 	IBM code
Upstream Acceptance 	Accepted
Component Release Version Target 	librtas-1.3.2
Documentation Work 	no

5. Hardware to Red Hat:  N/A

6. PM Contact: Josh Poulson, jrp@us.ibm.com, 360-857-5053

7. Technical Contact: Mike Strosaker, strosake@us.ibm.com, 512-838-9839
Comment 1 IBM Bug Proxy 2007-10-17 13:56:13 EDT
------- Comment From strosake@us.ibm.com 2007-10-17 13:51 EDT-------
The latest source tarball can be downloaded from the community site at
http://librtas.ozlabs.org/
Comment 2 Kevin Krafthefer 2007-10-17 16:02:04 EDT
RHEL4.7 is focused more on stability opposed to feature enablement. At this
point in the product's lifecycle we're avoiding adding support for additional,
new packages. 

Perhaps the RHEL4 is appropriate http://fedoraproject.org/wiki/EPEL

-RHEL Product Management
Comment 3 RHEL Product and Program Management 2007-10-17 16:02:35 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 
Comment 4 IBM Bug Proxy 2007-11-01 14:35:30 EDT
------- Comment From sglass@us.ibm.com 2007-11-01 14:34 EDT-------
Quiting this feature request as WontFix since REd Hat will not take it.

Note You need to log in before you can comment on or make changes to this bug.