Bug 332791 - refresh problems with ATI Radeon X1300
refresh problems with ATI Radeon X1300
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-vesa (Show other bugs)
5.1
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
: Triaged
: 312751 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-15 12:18 EDT by Jay Berkenbilt
Modified: 2014-06-09 09:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ejb: needinfo-


Attachments (Terms of Use)
first screenshot (7.65 KB, image/png)
2007-10-15 12:18 EDT, Jay Berkenbilt
no flags Details
second screenshot (11.60 KB, image/png)
2007-10-15 12:19 EDT, Jay Berkenbilt
no flags Details
Xorg.0.log with no xorg.conf (103.21 KB, text/plain)
2007-10-16 12:40 EDT, Jay Berkenbilt
no flags Details
Xorg.0.log with xorg.conf generated by system-config-display (93.78 KB, text/plain)
2007-10-16 12:41 EDT, Jay Berkenbilt
no flags Details
system-conf-display-generated xorg.conf with free drivers (684 bytes, text/plain)
2007-10-16 12:42 EDT, Jay Berkenbilt
no flags Details

  None (edit)
Description Jay Berkenbilt 2007-10-15 12:18:10 EDT
Description of problem:

Using Fedora 7, I am having odd refresh problems on partially obscured windows
in some cases.  In particular, a partially obscured xterm or emacs window fails
to refresh properly.  Certain parts of the window fail to erase when being
redrawn, so you have garbage left over from previous contents of the windows.

I have observed this problem with both the ATI/radeon drivers that come "out of
the box" with Fedora 7 and also wit the proprietary ATI drivers.  I have also
seen this with both the 2.6.21 kernel and the 2.6.22 kernel.  I also see the
problem with the vesa drivers.


Version-Release number of selected component (if applicable):

I'm not really sure exactly what component is at fault here.  I'll provide
several versions of things.


% cat /proc/version 
Linux version 2.6.21-1.3194.fc7 (kojibuilder@xenbuilder4.fedora.phx.redhat.com)
(gcc version 4.1.2 20070502 (Red Hat 4.1.2-12)) #1 SMP Wed May 23 22:35:01 EDT 2007

% rpm -qa | grep xorg
xorg-x11-apps-7.1-4.fc7
xorg-x11-fonts-100dpi-7.1-3.fc7
xorg-x11-drv-evdev-1.1.2-3.fc7
xorg-x11-drv-cirrus-1.1.0-3.fc7
xorg-x11-drv-mutouch-1.1.0-3.fc7
xorg-x11-drv-tdfx-1.3.0-4.fc7
xorg-x11-drv-dmc-1.1.0-3.fc7
xorg-x11-drv-s3-0.5.0-3.fc7
xorg-x11-drv-rendition-4.1.3-3.fc7
xorg-x11-drv-i810-2.0.0-4.fc7
xorg-x11-util-macros-1.1.5-1.fc7
xorg-x11-proto-devel-7.2-9.fc7
xorg-x11-drv-keyboard-1.1.0-3.fc7
xorg-x11-drv-void-1.1.0-4.fc7
xorg-x11-fonts-Type1-7.1-3.fc7
xorg-x11-drv-fpit-1.1.0-2.fc7
xorg-x11-drv-citron-2.2.0-2.fc7
xorg-x11-drv-elographics-1.1.0-2.fc7
xorg-x11-drv-savage-2.1.2-3.fc7
xorg-x11-drv-calcomp-1.1.0-2.fc7
xorg-x11-drv-trident-1.2.3-4.fc7
xorg-x11-drv-dynapro-1.1.0-3.fc7
xorg-x11-drv-ati-6.6.3-4.fc7
xorg-x11-xkb-utils-1.0.2-3.fc7
xorg-x11-fonts-ISO8859-1-75dpi-7.1-3.fc7
xorg-x11-xfs-1.0.2-3.1
xorg-x11-fonts-ISO8859-1-100dpi-7.1-3.fc7
xorg-x11-drv-mouse-1.2.1-2.fc7
xorg-x11-drv-hyperpen-1.1.0-3.fc7
xorg-x11-drv-mga-1.4.6.1-3.fc7
xorg-x11-drv-apm-1.1.1-3.fc7
xorg-x11-drv-aiptek-1.0.1-3.fc7
xorg-x11-drv-vmmouse-12.4.0-2.1
xorg-x11-drv-sis-0.9.3-2.fc7
xorg-x11-drv-voodoo-1.1.0-4.fc7
xorg-x11-drv-i740-1.1.0-3.fc7
xorg-x11-drv-spaceorb-1.1.0-2.fc7
xorg-x11-drv-digitaledge-1.1.0-2.fc7
xorg-x11-drv-ur98-1.1.0-2.fc7
xorg-x11-drv-palmax-1.1.0-2.fc7
xorg-x11-drv-summa-1.1.0-2.fc7
xorg-x11-drivers-7.2-6.fc7
xorg-x11-server-Xorg-1.3.0.0-9.fc7
xorg-x11-drv-nouveau-2.0.96-2.fc7
xorg-x11-filesystem-7.1-2.fc6
xorg-x11-twm-1.0.1-3.1
xorg-x11-xtrans-devel-1.0.3-1.fc7
xorg-x11-docs-1.3-1.fc7
xorg-x11-xdm-1.1.3-1.fc7
xorg-x11-fonts-base-7.1-3.fc7
xorg-x11-fonts-75dpi-7.1-3.fc7
xorg-x11-drv-fbdev-0.3.1-2.fc7
xorg-x11-drv-microtouch-1.1.0-2.fc7
xorg-x11-drv-magictouch-1.0.0.5-3.fc7
xorg-x11-drv-cyrix-1.1.0-4
xorg-x11-drv-ast-0.81.0-4.fc7
xorg-x11-drv-jamstudio-1.1.0-2.fc7
xorg-x11-drv-s3virge-1.9.1-3.fc7
xorg-x11-drv-chips-1.1.1-3.fc7
xorg-x11-drv-acecad-1.1.0-3.fc7
xorg-x11-drv-i128-1.2.0-5.fc7
xorg-x11-drv-v4l-0.1.1-5.fc7
xorg-x11-drv-siliconmotion-1.5.1-1.fc7
xorg-x11-drv-neomagic-1.1.1-2.1
xorg-x11-drv-nv-2.0.96-2.fc7
xorg-x11-xauth-1.0.2-1.fc7
xorg-x11-server-utils-7.2-1.fc7
xorg-x11-font-utils-7.1-5.fc7
xorg-x11-utils-7.1-4.fc7
xorg-x11-fonts-truetype-7.1-3.fc7
xorg-x11-drv-nsc-2.8.1-3.fc7
xorg-x11-drv-sisusb-0.8.1-5.fc7
xorg-x11-drv-ark-0.6.0-3.fc7
xorg-x11-drv-dummy-0.2.0-3.fc7
xorg-x11-drv-amd-0.0-9.20061016git.fc7
xorg-x11-drv-via-0.2.2-1.fc7
xorg-x11-xinit-1.0.2-22.fc7
xorg-x11-fonts-misc-7.1-3.fc7
xorg-x11-drv-glint-1.1.1-5.fc7
xorg-x11-drv-magellan-1.1.0-2.fc7
xorg-x11-drv-vmware-10.14.1-1.fc7
xorg-x11-drv-penmount-1.1.0-3.fc7
xorg-x11-drv-tseng-1.1.0-5.fc7
xorg-x11-drv-tek4957-1.1.0-2.fc7
xorg-x11-drv-vesa-1.3.0-8.fc7

% lspci -v

00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
	Subsystem: Dell Unknown device 01da
	Flags: bus master, fast devsel, latency 0
	Capabilities: [e0] Vendor Specific Information

00:01.0 PCI bridge: Intel Corporation 82Q963/Q965 PCI Express Root Port (rev 02)
(prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 0000d000-0000dfff
	Memory behind bridge: dfd00000-dfefffff
	Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
	Capabilities: [88] Subsystem: Dell Unknown device 01da
	Capabilities: [80] Power Management version 3
	Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
	Capabilities: [a0] Express Root Port (Slot+) IRQ 0

00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Contoller #4 (rev 02) (prog-if 00 [UHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 16
	I/O ports at ff20 [size=32]

00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #5 (rev 02) (prog-if 00 [UHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 17
	I/O ports at ff00 [size=32]

00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #2 (rev 02) (prog-if 20 [EHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 20
	Memory at dfffbc00 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Debug port

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 02)
	Subsystem: Dell Unknown device 01da
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at dfffc000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [70] Express Unknown type IRQ 0

00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 02) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	Memory behind bridge: dfc00000-dfcfffff
	Capabilities: [40] Express Root Port (Slot+) IRQ 0
	Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
	Capabilities: [90] Subsystem: Dell Unknown device 01da
	Capabilities: [a0] Power Management version 2

00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5
(rev 02) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	Memory behind bridge: dfb00000-dfbfffff
	Capabilities: [40] Express Root Port (Slot+) IRQ 0
	Capabilities: [80] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
	Capabilities: [90] Subsystem: Dell Unknown device 01da
	Capabilities: [a0] Power Management version 2

00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 02) (prog-if 00 [UHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 18
	I/O ports at ff80 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 02) (prog-if 00 [UHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 17
	I/O ports at ff60 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #3 (rev 02) (prog-if 00 [UHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 19
	I/O ports at ff40 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #1 (rev 02) (prog-if 20 [EHCI])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, medium devsel, latency 0, IRQ 18
	Memory at ff980800 (32-bit, non-prefetchable) [size=1K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Debug port

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2) (prog-if 01
[Subtractive decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=32
	Capabilities: [50] Subsystem: Dell Unknown device 01da

00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface
Controller (rev 02)
	Flags: bus master, medium devsel, latency 0
	Capabilities: [e0] Vendor Specific Information

00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE
Controller (rev 02) (prog-if 8f [Master SecP SecO PriP PriO])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 21
	I/O ports at fe00 [size=8]
	I/O ports at fe10 [size=4]
	I/O ports at fe20 [size=8]
	I/O ports at fe30 [size=4]
	I/O ports at fec0 [size=16]
	I/O ports at ecc0 [size=16]
	Capabilities: [70] Power Management version 3

00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
	Subsystem: Dell Unknown device 01da
	Flags: medium devsel, IRQ 21
	Memory at dfffbb00 (32-bit, non-prefetchable) [size=256]
	I/O ports at ece0 [size=32]

00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE
Controller (rev 02) (prog-if 85 [Master SecO PriO])
	Subsystem: Dell Unknown device 01da
	Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 21
	I/O ports at fe40 [size=8]
	I/O ports at fe50 [size=4]
	I/O ports at fe60 [size=8]
	I/O ports at fe70 [size=4]
	I/O ports at fed0 [size=16]
	I/O ports at ecd0 [size=16]
	Capabilities: [70] Power Management version 3

01:00.0 VGA compatible controller: ATI Technologies Inc RV516 [Radeon
X1300/X1550 Series] (prog-if 00 [VGA])
	Subsystem: Dell Unknown device 0d02
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at dfde0000 (64-bit, non-prefetchable) [size=64K]
	I/O ports at dc00 [size=256]
	Expansion ROM at dfe00000 [disabled] [size=128K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Express Endpoint IRQ 0
	Capabilities: [80] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-

01:00.1 Display controller: ATI Technologies Inc RV516 [Radeon X1300 Pro]
(Secondary)
	Subsystem: Dell Unknown device 0d03
	Flags: bus master, fast devsel, latency 0
	Memory at dfdf0000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [50] Power Management version 2
	Capabilities: [58] Express Endpoint IRQ 0

03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit
Ethernet PCI Express (rev 02)
	Subsystem: Dell Unknown device 01da
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at dfbf0000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [48] Power Management version 3
	Capabilities: [50] Vital Product Data
	Capabilities: [58] Vendor Specific Information
	Capabilities: [e8] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [d0] Express Endpoint IRQ 0


Excerpt from /etc/sysconfig/hwconf:

class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc RV516 [Radeon X1300 Pro] (Secondary)"
vendorId: 1002
deviceId: 71a3
subVendorId: 1028
subDeviceId: 0d03
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  1
-
class: VIDEO
bus: PCI
detached: 0
driver: fglrx
desc: "ATI Technologies Inc RV516 [Radeon X1300/X1550 Series]"
vendorId: 1002
deviceId: 7183
subVendorId: 1028
subDeviceId: 0d02
pciType: 1
pcidom:    0
pcibus:  1
pcidev:  0
pcifn:  0

% cat /etc/X11/xorg.conf (but note: same results with vesa or non-proprietary
ati drivers)

# Xorg configuration created by system-config-display

Section "ServerFlags"
	Option "DontZap" "true"
EndSection

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "aticonfig-Screen[0]" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "ServerFlags"
	Option	    "DontZap" "true"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]"
	Driver      "fglrx"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]"
	Device     "aticonfig-Device[0]"
	Monitor    "aticonfig-Monitor[0]"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection



For what it's worth my system is a Dell OptiPlex 745 with a single display.

How reproducible:

always

Steps to Reproduce:
1. change the contents of a partially obscured xterm or emacs

Example 1:

 * create an xterm
 * cover the right edge of the xterm with another window
 * do something to get the cursor near the bottom of the xterm
 * run repeat 5 sh -c "echo -n test; sleep 1; echo ''"
 * result in attachment "example-1.png"
Observe the pink junk leftover from where the cursor stopped after each echo
statement.

Example 2:

 * create an emacs window that is as high as the screen
 * run M-x ediff-files to compare two files
 * result in attaching "example-2.png"

The part of the emacs window that is horizontally aligned with the bottom of the
ediff control pane is not refreshed properly.

Note that simply obscuring the corrupted part of the display and then reshowing
it to force a redisplay or running a program such as xrefresh will properly
refresh the display.  However, since "import" (which I used to capture the
screen shots) is capturing the corrupted images, this not just some kind of
monitor anomaly or something.

Note also that this problem is reproducible if I clear my X resources.


Additional info:

I'm not running gnome or KDE.  I'm running straight X with xterms and emacs.

I will attempt to reproduce this problem using a vanilla login and see what happens.
Comment 1 Jay Berkenbilt 2007-10-15 12:18:11 EDT
Created attachment 227781 [details]
first screenshot
Comment 2 Jay Berkenbilt 2007-10-15 12:19:04 EDT
Created attachment 227791 [details]
second screenshot
Comment 3 Jay Berkenbilt 2007-10-15 12:30:52 EDT
I was able to reproduce this problem without any difficulty using a completely
vanilla new user logging in with a default login.  The problem could be
reproduced by using ediff as long as the ediff control frame was moved down into
the main part of the emacs frame so that it partially obscured part of one of
the frames that was being diffed.  This rules out my environment.
Comment 4 Matěj Cepl 2007-10-16 10:44:47 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) USING OPEN SOURCE DRIVERS ONLY to the bug report as
individual uncompressed file attachments using the bugzilla file attachment link
below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

For instructions on have to be sure, that no binary drivers are present (and
explanation why we are so hard against their use) see
http://fedoraproject.org/wiki/Xorg/3rdPartyVideoDrivers

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 5 Jay Berkenbilt 2007-10-16 12:40:18 EDT
Created attachment 228961 [details]
Xorg.0.log with no xorg.conf

This is the Xorg.0.log when starting X after removing the ATI proprietary
drivers and rebooting (to be sure the kernel module wasn't loaded).
Comment 6 Jay Berkenbilt 2007-10-16 12:41:21 EDT
Created attachment 228971 [details]
Xorg.0.log with xorg.conf generated by system-config-display

This is the Xorg.0.log when starting X from a config generated by
system-config-display (also attached) using only open source drivers.  In this
case, the vesa driver was selected.
Comment 7 Jay Berkenbilt 2007-10-16 12:42:00 EDT
Created attachment 228981 [details]
system-conf-display-generated xorg.conf with free drivers

Here is the xorg.conf that was in use when Xorg.0.log-system-config-display was
generated.
Comment 8 Jay Berkenbilt 2007-10-16 12:47:29 EDT
I uninstalled the ATI proprietary drivers which I had only installed to see if
they fixed the problem.  I have attached the xorg.conf and the two log files you
requested.

Although I didn't run rpm -Va, I did run

rpm -qa | grep GL | xargs rpm --verify
rpm -qa | grep xorg | xargs rpm --verify

I had installed the ATI drivers from rpms.  I inspected the rpms to ensure that
they didn't overwrite any standard libraries.  (They install alternative
libraries and create a file in ld.so.conf.d, which the removal of the rpm
successfully removed.)

I've got rpm -Va running now, and I'll reinstall any libraries that need to be
reinstalled, but I know that this problem was definitely present before the
proprietary drivers ever touched my system.

I was able to reproduce the bug with both of the X configurations posted to this
bug report and am in fact able to reproduce the bug now.

The only advantage I gained from using the proprietary drivers was that DPMS
worked.  If I am not able to get DPMS working with the free drivers, I'll post
that as a separate bug.
Comment 9 Jay Berkenbilt 2007-10-16 13:14:28 EDT
fwiw, I reinstalled 

freeglut-2.4.0-11.fc7
glx-utils-6.5.2-10.fc7
mesa-libGL-devel-6.5.2-10.fc7
mesa-libGLU-6.5.2-10.fc7

which had some changes and it made no difference: the bug is still there.  I
should be back to a clean configuration now.
Comment 10 Dave Airlie 2007-10-16 18:32:53 EDT
this is a vesa driver issue, the ati driver doesn't support the X1300.
Comment 11 Jay Berkenbilt 2007-10-16 18:37:20 EDT
Oh, geez.  You're right.  Even when I had the proprietary drivers installed, I
was actually using the vesa driver.  I guess I didn't look that carefully at the
xorg.conf.  Also, the DPMS problem was a red herring.  I didn't have option DPMS
"true" in xorg.conf.
Comment 12 Jay Berkenbilt 2007-11-15 14:19:35 EST
just reporting that this problem is still there with fedora 8.  This is a
completely clean install.  Proprietary drivers have never touched the system.
Comment 13 Jay Berkenbilt 2007-11-26 12:52:16 EST
For what it's worth, I'm not sure this is really a vesa driver issue.  After
trying with the latest ATI proprietary drivers released 11/21/2007 and ensuring
that I am actually using them, I still see the problem.  So there is some code
somewhere that is used both when the VESA drivers are in use and when the ATI
drivers are in use.  Perhaps this is lower level kernel VESA code or something.
Comment 14 Matěj Cepl 2008-02-18 18:30:43 EST
*** Bug 312751 has been marked as a duplicate of this bug. ***
Comment 15 Jay Berkenbilt 2008-05-09 21:11:26 EDT
I have verified that this happens with Red Hat Enterprise Linux Workstation 5.1
as well as with Fedora 7 and 8.  I also verified that the problem does NOT
happen with the latest release of the radeonhd driver (1.2.1).  Using radeonhd,
my display behaves properly.  I haven't tried anything that requires
acceleration or dual monitors, so I can't comment on radeonhd's general
suitability, but I definitely don't have this problem with that driver.
Comment 16 RHEL Product and Program Management 2014-03-07 08:46:14 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 17 Jay Berkenbilt 2014-03-07 09:19:46 EST
I don't have this hardware anymore nor am I still running RHEL 5 anywhere.  This can be closed at any time.
Comment 18 RHEL Product and Program Management 2014-06-02 09:20:39 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.