Bug 33329 - Gnorpm no longer prompts for root passwd.
Gnorpm no longer prompts for root passwd.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-26 19:55 EST by Ed McKenzie
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 15:21:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2001-03-26 19:55:23 EST
The GNOME menu now launches 'gnorpm' instead of 'gnorpm-auth' as in 7.0,
skipping root authentication and making gnorpm somewhat less useful a tool.
Is this a bug or feature?
Comment 1 David Lawrence 2001-04-03 14:39:49 EDT
Does this still happen if you run gnorpm-auth instead of gnorpm?
Comment 2 Ed McKenzie 2001-04-03 14:55:38 EDT
Running gnome-auth gives the expected results; changing gnorpm->gnorpm-auth in
the menu editor fixes the problem.
Comment 3 Ed McKenzie 2001-04-06 17:47:46 EDT
This is still broken after updating from the newest Rawhide. Is gnorpm no longer
supposed to prompt for the root password?
Comment 4 Alan Cox 2001-05-03 10:33:30 EDT
This seems to be a bug. Gnorpm does now have a non-root mode but its not what RH
users expect. Confirmed in 7.1
Comment 5 pogosyan 2001-07-07 11:27:58 EDT
In /usr/share/gnome/apps/System/gnorpm.desktop  one should replace
Exec=gnorpm   for
Exec=gnorpm-auth

line
Comment 6 Alexander Larsson 2001-07-12 15:21:45 EDT
I've fixed this now. Whenever 0.96-5 reaches RAWHIDE I will mark this bug fixed.
Comment 7 Alexander Larsson 2001-07-25 11:05:13 EDT
In rawhide now.

Note You need to log in before you can comment on or make changes to this bug.