Bug 33357 - corrupted executable file on NFS volume
corrupted executable file on NFS volume
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-27 02:04 EST by vincent gueno
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:08:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vincent gueno 2001-03-27 02:04:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (X11; I; SunOS 5.5.1 sun4u)


When I generate an executable file with gcc on NFS volume, then executable
file is corrupted (segmentation fault at execution) .To solve this problem,
I have to generate executable
  file on /tmp then move it to NFS volume. Is there a patch to solve such a
problem ? (gcc version 2.96 20000731 (Red Hat Linux 7.0))


Reproducible: Sometimes
Steps to Reproduce:
1.Link a program on NFS volume
2.
3.
Comment 1 Jakub Jelinek 2001-03-30 03:06:00 EST
If gcc creates the program just fine on local file system, then the bug is
either in the NFS client, or NFS server but not in gcc. gcc (well, it is
more probably as or ld, because if assembly was corrupted, it would most probably
not assemble) simply writes a file, it does not check what filesystem it is on.
You haven't mentioned which NFS server you're using.
Comment 2 Alan Cox 2003-06-05 20:08:51 EDT
Solaris and IBM server patches were released for this

Note You need to log in before you can comment on or make changes to this bug.