Bug 333571 - Can't Upgrade OpenEXR
Can't Upgrade OpenEXR
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: OpenEXR (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 02:57 EDT by Marc Wiriadisastra
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 05:01:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Wiriadisastra 2007-10-16 02:57:02 EDT
Description of problem:
A yum upgrade fails due to dependency issues.

Version-Release number of selected component (if applicable):


How reproducible:
Very happens every time.

Steps to Reproduce:
1. yum -y upgrade
  
Actual results:
Stops with dependency issues.

Expected results:
It should continue and upgrade to the latest rawhide version of OpenEXR

Additional info:
[marc@strikeforce SRPMS]$ sudo yum -y update OpenEXR 
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package OpenEXR.i386 0:1.6.0-4.fc8 set to be updated
--> Processing Dependency: libIlmImf.so.6 for package: OpenEXR
--> Processing Dependency: libIex.so.6 for package: OpenEXR
--> Processing Dependency: OpenEXR-libs = 1.6.0-4.fc8 for package: OpenEXR
--> Processing Dependency: libIlmThread.so.6 for package: OpenEXR
--> Processing Dependency: libImath.so.6 for package: OpenEXR
--> Processing Dependency: libHalf.so.6 for package: OpenEXR
--> Running transaction check
---> Package ilmbase.i386 0:1.0.0-3.fc8 set to be updated
---> Package OpenEXR-libs.i386 0:1.6.0-4.fc8 set to be updated
--> Processing Dependency: libHalf.so.4 for package: kdelibs
--> Processing Dependency: libIlmImf.so.4 for package: kdelibs
--> Finished Dependency Resolution
Error: Missing Dependency: libHalf.so.4 is needed by package kdelibs
Error: Missing Dependency: libIlmImf.so.4 is needed by package kdelibs

[marc@strikeforce SRPMS]$ rpm -qa kdelibs
kdelibs-3.5.8-2.fc8
Comment 1 Nicolas Chauvet (kwizart) 2007-10-16 05:01:39 EDT
For now use:
yum update --exclude=OpenEXR

Rebuild of OpenEXR dependents packages where spaced by 30min and kdelibs is
already rebuild but OpenEXR hit repository before others rebuilt packages were
done...

This will be fixed on next push...
for now only blender is missing the rebuild list, so i will close the bug to
rawhide now...


Note You need to log in before you can comment on or make changes to this bug.