Bug 33371 - Network daemon fails to bring up eth0.
Summary: Network daemon fails to bring up eth0.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-27 12:43 UTC by Toomas Gavrilin
Modified: 2014-03-17 02:20 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-03-28 06:49:41 UTC


Attachments (Terms of Use)

Description Toomas Gavrilin 2001-03-27 12:43:35 UTC
'interfaces=...' part in /etc/rc.d/init.d/network filters out ifcfg-eth0
due to the line "egrep 'ifcfg-[a-z0-9]+$' ". As a temporary solution I just
removed $ sign, bu tI'm open to suggestions.

Comment 1 Bill Nottingham 2001-03-27 16:07:48 UTC
I can't reproduce this here; doing:

ls ifcfg-eth0 | egrep 'ifcfg-[a-z0-9]+$' 
prints
ifcfg-eth0

fine here.

Comment 2 Toomas Gavrilin 2001-03-28 06:48:16 UTC
 Exactly the same line gives me nothing here, and there's definitely ifcfg-eth0.
Maybe egrep isn't happy with Estonian locale?


Comment 3 Bill Nottingham 2001-03-28 16:21:58 UTC
Hm, probably. Will be fixed in 5.81-1.


Note You need to log in before you can comment on or make changes to this bug.