Bug 333771 - autofs fails if LDAP attribute value is the same as a standard autofs attribute name
autofs fails if LDAP attribute value is the same as a standard autofs attribu...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
low Severity low
: rc
: ---
Assigned To: Ian Kent
Brock Organ
: Regression
: 333751 (view as bug list)
Depends On:
Blocks: 425885
  Show dependency treegraph
 
Reported: 2007-10-16 05:16 EDT by Ian Kent
Modified: 2008-05-21 10:38 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:38:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to prevent autofs from confusing a value that is the same as an attribute (355 bytes, patch)
2007-10-16 05:16 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2007-10-16 05:16:13 EDT
Description of problem:
autofs fails if LDAP attribute value is the same as a
standard autofs attribute name.

Version-Release number of selected component (if applicable):
autofs-5.0.1-0.rc2.55

How reproducible:
Always.

Steps to Reproduce:
1. Add this line to the autofs master map, auto.master:
/test  ldap://server/ou=auto.test,dc=ou,dc=bogus
  
Actual results:
autofs fails to start and issues the message:
master_error: syntax error while parsing map

Expected results:
autofs correctly identifies the troublesome value as
a value.
Comment 1 Ian Kent 2007-10-16 05:16:13 EDT
Created attachment 228451 [details]
Patch to prevent autofs from confusing a value that is the same as an attribute
Comment 2 RHEL Product and Program Management 2007-10-16 05:24:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 RHEL Product and Program Management 2007-10-16 05:25:49 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 4 Ian Kent 2007-11-15 07:15:56 EST
This issue is resolved in aut0fs-5.0.1-0.rc2.65.
The RHTS sub test bz333771 under autofs-tests/bugzillas can
be used to verify this bug.
Comment 6 Ian Kent 2008-01-08 04:11:56 EST
*** Bug 333751 has been marked as a duplicate of this bug. ***
Comment 9 errata-xmlrpc 2008-05-21 10:38:09 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.